[Vertical] Icon does not drop properly during edit mode

VERIFIED FIXED in Firefox OS v2.0

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: kgrandon, Assigned: kgrandon)

Tracking

unspecified
2.0 S4 (20june)
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
It appears that we have a bunch of bugs related to icons and them not dropping in the desired location. It's highly likely that a single patch will solve all of them, so creating a bug to track that work and will re-shift some bugs to clear up the dependency tree.

Johan/Jason - let me know if you have any problems with this approach, thanks.
(Assignee)

Updated

4 years ago
Depends on: 1021329
(Assignee)

Updated

4 years ago
Depends on: 1021382
(Assignee)

Updated

4 years ago
Depends on: 1021554
(Assignee)

Updated

4 years ago
Depends on: 1019751
(Assignee)

Updated

4 years ago
Depends on: 1021512
(Assignee)

Updated

4 years ago
Depends on: 1021311
(In reply to Kevin Grandon :kgrandon from comment #0)
> It appears that we have a bunch of bugs related to icons and them not
> dropping in the desired location. It's highly likely that a single patch
> will solve all of them, so creating a bug to track that work and will
> re-shift some bugs to clear up the dependency tree.
> 
> Johan/Jason - let me know if you have any problems with this approach,
> thanks.

Sounds fine to me - I'll nom this one to block instead of the dependencies to simplify this as well.
blocking-b2g: --- → 2.0?

Updated

4 years ago
Whiteboard: [systemsfe]

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
No longer depends on: 1021329

Updated

4 years ago
Depends on: 1023039
QA Whiteboard: [VH-FC-blocking+]
Target Milestone: --- → 2.0 S4 (20june)

Updated

4 years ago
QA Whiteboard: [VH-FC-blocking+] → [VH-FL-blocking-][VH-FC-blocking+]
Assignee: nobody → kgrandon
(Assignee)

Comment 2

4 years ago
Created attachment 8440411 [details] [review]
Github pull request

Just looking for a review for this dragdrop stuff. I also want to write some marionette tests to cover this stuff, but it seems a bit tricky - I'll work with you on that soon James.

Cwiiis - It's likely that this could conflict a lot with your patch in bug 1022713. While I do want to see these performance fixes land, it's super important that we get the "stuck icon" thing solved. This patch seems to do that by using min/max to get from and to, then buffering that a bit in the case of divider creation/deletion.
Attachment #8440411 - Flags: review?(jlal)
Attachment #8440411 - Flags: review?(crdlc)
Attachment #8440411 - Flags: review?(chrislord.net)
Comment on attachment 8440411 [details] [review]
Github pull request

TBH I don't see anything wrong although the buffer code seems a bit tricky. I bet  to remove the "from" and "to" parameters right now and we could work on investigating what happens here and also to obtain the proper indexes. But if you want to land it there is no problem at all for me
Attachment #8440411 - Flags: review?(crdlc) → review+
(Assignee)

Comment 4

4 years ago
The from/to parameters will be tricky to remove without a rewrite of a lot of the system due to the way that placeholders are created/removed and dividers are removed. Let's land for now and we can always optimize later. Thanks for the review.
(Assignee)

Updated

4 years ago
Attachment #8440411 - Flags: review?(jlal)
Attachment #8440411 - Flags: review?(chrislord.net)
(Assignee)

Comment 5

4 years ago
Landed: https://github.com/mozilla-b2g/gaia/commit/b752637348f182116c5fb2ae2596f9b89959def8
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1021554

Updated

4 years ago
No longer depends on: 1021554

Updated

4 years ago
No longer depends on: 1021311

Updated

4 years ago
No longer depends on: 1021382

Updated

4 years ago
No longer depends on: 1021512

Updated

4 years ago
No longer depends on: 1023039

Updated

4 years ago
No longer depends on: 1019751
Needs a branch patch for v2.0 uplift (or approval on what deps it has).
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → fixed
Flags: needinfo?(kgrandon)
Keywords: branch-patch-needed
(Assignee)

Comment 8

4 years ago
Thanks. I'm requesting approval on previous patches that are also necessary.
Flags: needinfo?(kgrandon)
Keywords: branch-patch-needed
Whiteboard: [systemsfe] → [systemsfe][NO_UPLIFT]
(Assignee)

Comment 9

4 years ago
Uplifted: https://github.com/mozilla-b2g/gaia/commit/f04e3e92f50141fec73e74800b6f3fc6d84fee34
status-b2g-v2.0: affected → fixed
Whiteboard: [systemsfe][NO_UPLIFT] → [systemsfe]
Created attachment 8531127 [details]
Verify_Video_Flame.MP4

This issue has been verified successfully on Flame 2.0 & 2.1.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/10

Flame v2.0 version:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141201000201
Version         32.0

Flame v2.1 version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.