Submission of a form does not always bring up next page.

VERIFIED DUPLICATE of bug 103850

Status

()

Core
HTML: Form Submission
VERIFIED DUPLICATE of bug 103850
17 years ago
17 years ago

People

(Reporter: Zac Jacobson, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20010927
BuildID:    2001092703

On several web sites that I use, the submission of a form causes the page to
reload, rather than loading the page that the form is suppoed to bring up.

I don't know much about the HTTP protocol, but have done some testing, please
see below.


Reproducible: Always
Steps to Reproduce:
1. As an example, got to http://java.sun.com/products/servlet/download.html
2. Click on the "Continue" button next to "Download class files 2.3"
3. You are presented with a lisence. Scroll down to the bottom, click the "I
accept" button.

Actual Results:  The page simply reloads.

Expected Results:  A Download page should be displayed, with a group of buttons
indicating download sites, etc.

We (the company I work for) has an interal timesheet web app, and Mozilla
exibits the same behaviour when using it. Here's what Mozilla sends from the
login page:

----------------------------------------------------------------
POST /scripts/wts.dll?FpLogin HTTP/1.1
Host: digby-esp
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20010927
Accept: text/xml, application/xml, application/xhtml+xml, text/html;q=0.9,
image/png, image/jpeg, image/gif;q=0.2, text/plain;q=0.8, text/css, */*;q=0.1
Accept-Language: en, pdf;q=0.50
Accept-Encoding: gzip, deflate, compress;q=0.9
Accept-Charset: ISO-8859-1, utf-8;q=0.66, *;q=0.66
Keep-Alive: 300
Connection: keep-alive
Content-type: application/x-www-form-urlencoded
Content-Length: 27

Alias=zjacobson&Pwd=alberta
----------------------------------------------------------------

and here's what is returned when I send that header and data to the same place.

----------------------------------------------------------------
HTTP/1.1 100 Continue
Server: Microsoft-IIS/5.0
Date: Fri, 28 Sep 2001 20:02:26 GMT
MicrosoftOfficeWebServer: 5.0_Pub

HTTP/1.1 200 OK
Server: Microsoft-IIS/5.0
Date: Fri, 28 Sep 2001 20:02:26 GMT
MicrosoftOfficeWebServer: 5.0_Pub
Connection: close
Refresh: 0; url='?Go'
<HTML><BODY></BODY></HTML>
----------------------------------------------------------------
The connection closes imediately after the final '>' there's no newline.

Like I say, I don't know that much about HTTP. I got the headers by using IE to
get the contents of the web page, editing the source to point to my own machine,
and running a simple Java app that just prints out what it hears, and returns
some simple HTML.

I then copied what mozilla sent me, changed the Host line, and used telnet to
send it to the machine it was meant for.

Comment 1

17 years ago
?
Assignee: asa → neeti
Component: Browser-General → Networking: HTTP
QA Contact: doronr → tever
Reporter: Is this still occuring for you in a more recent build?
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip
(as always, be sure to delete your old Mozilla directory before installing the
new one)

-> Form Submission
Assignee: neeti → rods
Component: Networking: HTTP → Form Submission
QA Contact: tever → vladimire
(Reporter)

Comment 3

17 years ago
I just got Build 2001102903, erased everything (except the plugins directory)
and installed the talkback build. I followed exactly the steps I outlined
before, and suffered the same results.

... is it possible that this is an environment problem? I've had a different
form submission problem with Mozilla before (couldn't submit to a dll), when I
was using NT, but the bug got marked as WFM. It wasn't until I did a full
harddisk format and a clean install of win2000 that it started working again.

Zac (Reporter)

Comment 4

17 years ago
->
Assignee: rods → alexsavulov
Zac: Have you tried a fresh profile? You can manage/create profiles with
"mozilla.exe -profilemanager".
(Reporter)

Comment 6

17 years ago
I just tried from a clean profile, and suffered the same behavior.
Zac: I tried the example you gave for Sun, and I got the error "ftp.java.sun.com
could not be found. Please check the name and try again."

However, downloads from alternate mirror sites was fine :-/.
(Assignee)

Comment 8

17 years ago
this is a dup of bug 103850

*** This bug has been marked as a duplicate of 103850 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

17 years ago
Alex: My browser never gets to the page where you can download anything. It just
displays the license agreement over and over.

I tried the cache things in the bug that this is apparently a duplicate of, and
that definitely solved the problem for the sun page.

Thanks.
Zac.
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.