Cannot add an e.me app to the homescreen via wrapper

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Search
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jsmith, Assigned: crdlc)

Tracking

({regression, smoketest})

unspecified
2.0 S4 (20june)
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Build

* Device: Flame
* Version: 2.0 - b2g-inbound
* Build ID: 20140608173002
* Gaia: 12af93123c5db55212d51fe235d39f21209a1eaa
* Gecko: 7f3f35b511f8

STR

1. Open rocketbar & search for google
2. Select the Google icon
3. Open the wrapper

Expected

There should be a star icon allowing the user to add the e.me app to the homescreen.

Actual

There is no star icon there to allow the user to add the e.me app to the homescreen.
(Reporter)

Comment 1

4 years ago
Fails smoketest - https://moztrap.mozilla.org/manage/case/5856/
Blocks: 989848
blocking-b2g: --- → 2.0+
QA Whiteboard: [2.0-rocketbar-FL-blocking+]
Keywords: regression, smoketest
Whiteboard: [systemsfe]
(Assignee)

Updated

4 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
Created attachment 8436827 [details]
Github pull request

Thanks mate
Attachment #8436827 - Flags: review?(kgrandon)
Attachment #8436827 - Flags: review?(dale)
(Assignee)

Updated

4 years ago
Component: Gaia::System → Gaia::Search
Comment on attachment 8436827 [details]
Github pull request

I asked some questions on github. Would like to see them addressed before giving an R+. Thanks!
Attachment #8436827 - Flags: review?(kgrandon)
Comment on attachment 8436827 [details]
Github pull request

Agreed that this doesnt seem like a feature we should be adding to the grid, we can add this unconditionally, and in future we wont need to do this at all as the bookmark button will be available all the time.
Attachment #8436827 - Flags: review?(dale)
(Assignee)

Comment 5

4 years ago
I am not agree. This feature is not needed for homescreen app. Bookmarks on homescreen have never show the star icon because they are already installed then it is not unconditional

(In reply to Dale Harvey (:daleharvey) from comment #4)
> Comment on attachment 8436827 [details]
> Github pull request
> 
> Agreed that this doesnt seem like a feature we should be adding to the grid,
> we can add this unconditionally, and in future we wont need to do this at
> all as the bookmark button will be available all the time.
(Assignee)

Comment 6

4 years ago
I have answered questions
I guess the concern is that the behavior in 2.1+ will change, but I suppose we should go with the easiest solution for 2.0 for now. I still feel weird about adding this as an attribute of the grid. I think that we should probably change the detail objects of bookmarks to allow for something special, or instantiate it a different way. I know it's a pain, but would it be difficult to explore doing something like the following:

var features = {search: true};
new Bookmark(detail, features);
(Assignee)

Comment 8

4 years ago
Sincerely I don't know how you want to know if we have to include search feature or not. I decided to include this as an attribute instead of checking the origin (origin === homescreen). What do you suggest to know it if I cannot add an attribute? Thanks
(Reporter)

Updated

4 years ago
Blocks: 1015336
No longer blocks: 989848
Sorry, to be more clear my suggestion is to see if there is some way that we can do it from the application side, when creating a grid object. This could potentially be part of the 'detail' object, or a new configuration.

E.g., you could update this: https://github.com/mozilla-b2g/gaia/blob/master/apps/search/js/providers/webresults.js#L54

To have something like: 
var features = {search: true};
new Bookmark(detail, features);

Cristian - is that any more clear?
Flags: needinfo?(crdlc)
(Reporter)

Updated

4 years ago
QA Whiteboard: [2.0-rocketbar-FL-blocking+] → [VH-FL-blocking+]
(Assignee)

Comment 10

4 years ago
yes
Flags: needinfo?(crdlc)
(Assignee)

Comment 11

4 years ago
Comment on attachment 8436827 [details]
Github pull request

thanks mates
Attachment #8436827 - Flags: review?(kgrandon)
Attachment #8436827 - Flags: review?(dale)
Target Milestone: --- → 2.0 S4 (20june)
Comment on attachment 8436827 [details]
Github pull request

Looks good to me, thanks!
Attachment #8436827 - Flags: review?(kgrandon)
Attachment #8436827 - Flags: review?(dale)
Attachment #8436827 - Flags: review+
Landed: https://github.com/mozilla-b2g/gaia/commit/ea4f0a93092daf8269b0b4410f6cd2d658c006e3
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Uplifted: https://github.com/mozilla-b2g/gaia/commit/f3e0fdd62c546e4086f0c52c0f0062c9ae7cb679
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Verified issue is fixed in 2.0 Flame

Result: Wrapper for e.me app shows favorite star

Environmental Variables:
Device: Flame 2.0
Build ID: 20140612000201
Gaia: 2bb66630315299ca947e40fcec23c9f7ea012111
Gecko: 670d69879f0e
Version: 32.0a2 (2.0) 
Firmware Version: v10G-2
Status: RESOLVED → VERIFIED
QA Whiteboard: [VH-FL-blocking+] → [VH-FL-blocking+], [QAnalyst-Triage?]
Verified 2.0: 

Gaia      23e06c3624309db22ad9cb736d89700768b42b36
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/164b61458ca5
BuildID   20140619000200
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
Flame
status-b2g-v2.0: fixed → verified
Verified fixed in Flame 2.1.
Issue no longer occurs.

Environmental Variables:
Device: Flame 2.1
BuildID: 20141021001201
Gaia: e458f5804c0851eb4e93c9eb143fe044988cecda
Gecko: ee86921a986f
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
status-b2g-v2.1: fixed → verified
Flags: needinfo?(pbylenga)
QA Whiteboard: [VH-FL-blocking+], [QAnalyst-Triage?] → [VH-FL-blocking+], [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.