message pane: Monospace font setting is ignored instead the setting for proportional font is used if browser.display.use_document_fonts is set to 0

RESOLVED FIXED in seamonkey2.30

Status

SeaMonkey
MailNews: Message Display
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Hartmut Figge, Assigned: jtd)

Tracking

({regression})

Trunk
seamonkey2.30
x86_64
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
If 'Allow documents to use other fonts' in Edit->Preferences->Appearance->Fonts is not checked, in the message pane the font selected in Proportional is used instead of the one selected in Monospace.

Regression range:
Last good: 2014-06-05 21:13:00 PDT m-c:4a552fb1ca38 c-c:9477e9a40a03
First bad: 2014-06-06 17:31:00 PDT m-c:62d33e3ba514 c-c:7f8eb9f73fe2

Comment 1

3 years ago
Created attachment 8436706 [details]
20140609-messagebody-font-01.jpg

Comment 2

3 years ago
Created attachment 8436708 [details]
20140609-messagebody-font-02.jpg
Attachment #8436706 - Attachment is obsolete: true

Comment 3

3 years ago
My last good build was
2014-06-06 15:04:28wstAustralia built from <https://hg.mozilla.org/mozilla-central/rev/7297cfffd91c>
Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 SeaMonkey/2.29a1 ID:20140606150428 CSet: 9477e9a40a03
which keeps the basic plain text Monospace irrespective of the preference-setting of
"Edit / Appearance / Fonts / Allow Documents to use other fonts",
and I even confirmed it worked OK through a suite shutdown - restart.
-----
After Hartmut highlighted the regression in the newsgroups, my next build had the regression.
2014-06-09 10:43:59wstAU built from <https://hg.mozilla.org/mozilla-central/rev/9305a8ec77fe>
Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 SeaMonkey/2.29a1 ID:20140609104359 CSet: 4b8ed969933d

Updated

3 years ago
Attachment #8436706 - Attachment is obsolete: false

Comment 4

3 years ago
Mozilla Central range:
<http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2014-06-06+02:06&enddate=2014-09-09+02:10>
Also check if Thunderbird is also affected.

Updated

3 years ago
Summary: message pane: Monospace font uses proportional font → message pane: Monospace font setting is ignored instead the setting for proportional font is used if browser.display.use_document_fonts is set to 0

Comment 5

3 years ago
Thunderbird is also affected:
For plain text message if "use fixed width for plain" is enabled, and "allow other fonts" is *disabled* the behaviour is changed -> font is not fixed
(Reporter)

Comment 6

3 years ago
Backout of the checkins in https://bugzilla.mozilla.org/show_bug.cgi?id=280443#c78 fixes the issue.

Comment 7

3 years ago
It isn't just Thunderbird.
Add-ons such as PDF.js are also being disabled by these CSS font family changes.

Comment 8

3 years ago
My error! Different problems apparently.
Just coincidental that PDF.js broke across these builds.
Sorry for the noise.

Updated

3 years ago
Depends on: 280443
(Assignee)

Updated

3 years ago
Assignee: nobody → jdaggett
(Assignee)

Comment 9

3 years ago
Created attachment 8438943 [details] [diff] [review]
patch, fix -moz-fixed handling in the no doc fonts case

Argh, missing break in a case statement...
Attachment #8438943 - Flags: review?(cam)
Attachment #8438943 - Flags: review?(cam) → review+
(Reporter)

Comment 10

3 years ago
The fix works for me.
(Assignee)

Comment 11

3 years ago
Created attachment 8438975 [details] [diff] [review]
patch, add a reftest for the no doc fonts case

Test passes but using the browser.display.use_document_fonts pref causes leaks, need to track those down.
(Assignee)

Comment 12

3 years ago
Comment on attachment 8438975 [details] [diff] [review]
patch, add a reftest for the no doc fonts case

Reftest tryserver run
https://tbpl.mozilla.org/?tree=Try&rev=175db85082f0
Attachment #8438975 - Flags: review?(cam)
Comment on attachment 8438975 [details] [diff] [review]
patch, add a reftest for the no doc fonts case

Review of attachment 8438975 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/reftests/bugs/1022481-1.html
@@ +2,5 @@
> +<html>
> +<head>
> +<title>Simple generics test</title>
> +<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
> +<style type="text/css">

(Did you know that these two lines can be written as:

  <meta charset="UTF-8">
  <style>

and they're exactly equivalent to the longer forms you have there.)
Attachment #8438975 - Flags: review?(cam) → review+
(Assignee)

Comment 14

3 years ago
(In reply to Cameron McCormack (:heycam) from comment #13)
> (Did you know that these two lines can be written as:
> 
>   <meta charset="UTF-8">
>   <style>
> 
> and they're exactly equivalent to the longer forms you have there.)

template updated... ;)
(Assignee)

Comment 15

3 years ago
Pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/63c8d0d214d7
https://hg.mozilla.org/integration/mozilla-inbound/rev/6c6c66292238
https://hg.mozilla.org/mozilla-central/rev/63c8d0d214d7
https://hg.mozilla.org/mozilla-central/rev/6c6c66292238
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.30
Duplicate of this bug: 1065016
You need to log in before you can comment on or make changes to this bug.