[Flame][V1.4][Keyboard]The space key always displays as Chinese string: "空格" when you switch between Chinese and English input method.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: panda67231, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 unaffected)

Details

(Whiteboard: bamboo)

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8436665 [details]
Switch.mp4

[1.Description]:
The Switch Icon display as Chinese string: "中/英" and the space key always displays as Chinese string:"空格" when you Tap the Switch Icon to switch between Chinese and English in Number input keyboard view.
Attach figure:[Switch.png]
Attach video:[Switch.mp4]
Attach log:[Switch_bugreport.txt & Switch_logcat.txt]
Happened time: 12:47PM

[2.Testing Steps]: 
Precondtion:You have checked Chinese and English keyboard in settings.
1. Launch message.
2. Tap Icon of Edit message.
3. Tap the message input box to toggle the keyboard.
4. Tap the Switch Icon to switch between Chinese and English input method.
** The Switch Icon display as the Symbol of ball.
5. Tap the Symbol key to toggle the Number input keyboard.
6. Tap the Switch Icon to switch between Chinese and English input method.
** The Switch Icon display as "中/英".
** The space key always displays as "空格".

[3.Expected Result]: 
6. The Switch Icon should display as the Symbol of ball and the space key should display nothing instead of  "空格" in English input keyboard.

[4.Actual Result]: 
6. The Switch Icon display as "中/英" and the space key always displays as "空格".

[5.Reproduction build]: 
Gaia        7709936aeb21859d1607dbd038489493803bb085
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/5bf038fae0f1
BuildID    20140522160202
Version    30.0

[6.Reproduction Frequency]: 
occasionally Recurrence,8/10
(Reporter)

Comment 1

4 years ago
Created attachment 8436669 [details]
Switch.png
(Reporter)

Comment 2

4 years ago
Created attachment 8436671 [details]
Switch_bugreport.txt
(Reporter)

Comment 3

4 years ago
Created attachment 8436673 [details]
Switch_logcat.txt
Blocks: 1015220
Status: UNCONFIRMED → NEW
Ever confirmed: true
Think this will only be a blocker if we release a 1.4 handset in China, but I don't know about that.
blocking-b2g: --- → 1.4?
Based on comment # 4 moving this to backlog
blocking-b2g: 1.4? → backlog
I would say this is by design, and we improve pinyin's layout again with bug 1021505.
So, I'll close this one as won't fix, and please re-open this if you still have any other concerns for the new design.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → unaffected
Resolution: --- → WONTFIX
(Assignee)

Updated

4 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.