Closed Bug 1022515 Opened 5 years ago Closed 5 years ago

Marketplace download suggestions still show up even if the app is installed

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 verified, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.0 S4 (20june)
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: jsmith, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

Build

* Device: Flame
* Version: 2.0 - b2g-inbound
* Build ID: 20140608173002
* Gaia: 12af93123c5db55212d51fe235d39f21209a1eaa
* Gecko: 7f3f35b511f8

STR

1. Install ConnectA2
2. Open rocketbar search
3. Search for ConnectA2

Expected

A marketplace download suggestion for ConnectA2 should not appear.

Actual

A marketplace download suggestion for ConnectA2 does appear.
Attached image Screenshot
Wrong behavior in a new 2.0 feature & this is a user-facing regression from moving to the new search experience, since e.me did filter out existing installed apps.
blocking-b2g: --- → 2.0?
Whiteboard: [systemsfe]
Blocks: 1015336
No longer blocks: vertical-homescreen
QA Whiteboard: [VH-FC-blocking-]
Thinking about this more, we can probably live with this. It's wrong behavior, but it's also low user impact.
blocking-b2g: 2.0? → ---
This actually used to work, but the marketplace changed their API looks like. We'll fix it.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.0 S4 (20june)
Attached file Github pull request
Hey Amir, Ran - Got time for a quick review? Thanks!
Attachment #8438851 - Flags: review?(ran)
Attachment #8438851 - Flags: review?(amirn)
Attachment #8438851 - Flags: review?(ran)
Attachment #8438851 - Flags: review?(amirn)
Attachment #8438851 - Flags: review+
Thanks for the review. Landed: https://github.com/mozilla-b2g/gaia/commit/ba365c8f7feda34e582ce1721cf538f417c92a75
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8438851 [details] [review]
Github pull request

This is needed for the vertical homescreen. We've put forward a best effort to believe that this is safe for uplift and the tree will remain green.
Attachment #8438851 - Flags: approval-gaia-v2.0?(bbajaj)
Attachment #8438851 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
Depends on: 1088983
This issue is verified fixed on Flame 2.0.

Result: The app appears as downloaded app on rocket bar search, without downloading suggestion.

Flame 2.0

Environmental Variables:
Device: Flame 2.0  (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141024000201
Gaia: 86d83f4b4111ca45ebc92ca779348cc966f43cff
Gecko: f8432250efb7
Version: 32.0 (2.0)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
==========================================

This issue still occurs on Flame 2.1 and 2.2. Filed a new bug 1088983.
QA Whiteboard: [VH-FC-blocking-] → [VH-FC-blocking-][QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [VH-FC-blocking-][QAnalyst-Triage?][failed-verification] → [VH-FC-blocking-][QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
The issue is no longer reproduces on Flame 2.2 and 2.1, changing as verified

The app appears as downloaded app on rocket bar search result without downloading suggestion

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141112040208
Gaia: 5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko: 688f821edcd4
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"

"Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141112001201
Gaia: 4c159e75a1568afbbf0c83c1235ec56facfbe87d
Gecko: b9849b3c6aaa
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [VH-FC-blocking-][QAnalyst-Triage+][failed-verification] → [VH-FC-blocking-][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [VH-FC-blocking-][QAnalyst-Triage?] → [VH-FC-blocking-][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This was fixed following Jason's original steps in Comment 0 but with slightly modified steps, the issue is still occurring. This has been written up in bug 1088983
You need to log in before you can comment on or make changes to this bug.