Closed Bug 1022541 Opened 7 years ago Closed 7 years ago

[Camera][Gecko] Continuous callbacks after Taking a picture

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 994912

People

(Reporter: shinuk153, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.114 Safari/537.36

Steps to reproduce:

Considering new shot mode - 'continuous shot'

After taking a picture, continuous callbacks(images) received from Camera HAL.



Actual results:

After nsDOMCameraControl::OnTakePictureComplete(nsIDOMBlob* aPicture) has done,
mTakePictureOnSuccessCb will be forgotten.

That is another callback from Camera HAL cannot be passed to App because there is no callback function available.


Expected results:

To make subsequent callbacks enable, mTakePictureOnSuccessCb needs to be deleted when nsDOMCameraControl::ResumePreview(ErrorResult& aRv) is called. - When all continuous callbacks are completed.
shinuk, in bug 994912, we're working on a patch to migrate the callbacks to proper DOMEvents.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: camera-events
You need to log in before you can comment on or make changes to this bug.