[WAP Push][CP] The header of a cp message shows a wrong label for a second, then it changes

RESOLVED FIXED in Firefox OS v2.0

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: isabelrios, Assigned: gsvelto)

Tracking

({regression})

unspecified
2.0 S4 (20june)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8436797 [details]
VID_20140609_100555.3gp

Seen on today's (06/09) master buri build:
Gecko-1a316f5
Gaia-deed49c

1. Receive a oma cp message
2. Check the header shown

EXPECTED
The header shows the number from which the message is received

ACTUAL
The header shows for a while 'wap push message' then the correct number from which the message is received.

Please see video file attached.
This is a regression as it is working fine in 1.3
(Assignee)

Comment 1

4 years ago
I think this problem has always been present, it might have not been visible in the past because the app launched too fast for a user to notice. The issue might be caused by the following piece of code:

https://github.com/mozilla-b2g/gaia/blob/486df91971aec283a6c0ba7f194e196006ff7d37/apps/wappush/js/wappush.js#L219

When responding to a notification click we're launching the app before having populated the screen; so if the following routine is not fast enough the user might see an unpopulated screen hence the "WAP Push Message" title.
QA Wanted to check past branches.
Keywords: qawanted
(Assignee)

Comment 3

4 years ago
I tried delaying the |app.launch()| call but it doesn't seem to help. I'll try modifying the application to not show any other title before the message number; this should also fix the bug preventing the glitch from happening.
(Assignee)

Comment 4

4 years ago
Created attachment 8437051 [details] [diff] [review]
[PATCH] Don't show the "WAP Push Message" string in the header when opening a message

Here's a patch that ensures that the title is empty before opening a message, the first title shown will be the sender's number.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
(Assignee)

Comment 5

4 years ago
Created attachment 8437052 [details] [review]
[PULL REQUEST] Don't show the "WAP Push Message" string in the header when opening a message

Here's the associated pull request; Isabel can you verify that this change solves the problem?
Flags: needinfo?(isabelrios)
(Reporter)

Comment 6

4 years ago
Hi Gabriel, sure, I will check it and comment the result.

Thanks
Flags: needinfo?(isabelrios)
(Reporter)

Comment 7

4 years ago
Hi Gabriele,

Your patch is working ok, thanks! Only the number from which the message is received is shown in the header.
(Assignee)

Comment 8

4 years ago
Comment on attachment 8437051 [details] [diff] [review]
[PATCH] Don't show the "WAP Push Message" string in the header when opening a message

The patch is almost trivial but comes with a test (you never know), if you r+ this can you land it for me? I had a quick look at bugmail today in a moment of quiet but I won't have time later, you know why :)
Attachment #8437051 - Flags: review?(felash)

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Comment on attachment 8437051 [details] [diff] [review]
[PATCH] Don't show the "WAP Push Message" string in the header when opening a message

Review of attachment 8437051 [details] [diff] [review]:
-----------------------------------------------------------------

I'm actually wondering if it's better to have "Wap Push Message" in the header or an empty header while the number is retrieved.
Vicky, are you the right person to answer comment 9?
Flags: needinfo?(vpg)
(In reply to Julien Wajsberg [:julienw] from comment #10)
> Vicky, are you the right person to answer comment 9?

I think this is more of an IA issue. Flagging Jenny to give input.
Flags: needinfo?(vpg) → needinfo?(jelee)

Comment 12

4 years ago
A quick question, from video attachment 8436797 [details], I see the number from the message is already there in notification, can't we use it upon launching the app? 
If we can't avoid the gap between retrieving the number and showing, I prefer empty header over showing "Wap Push Message" because the current behavior looks pretty buggy. Tks!
Flags: needinfo?(jelee)
Thanks Jenny,

Then I'll move forward with the current patch and file a separate bug for this suggestion, so that Gabriele can have a look at it later.
Filed bug 1025888 for Jenny's suggestion.
Comment on attachment 8437051 [details] [diff] [review]
[PATCH] Don't show the "WAP Push Message" string in the header when opening a message

Review of attachment 8437051 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, waiting for a green travis before merging.
Attachment #8437051 - Flags: review?(felash) → review+
master: b82043faaafb8e108eb9591d40f01e6e5838ce66
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
v2.0: https://github.com/mozilla-b2g/gaia/commit/86e5fd177d1fe931c494decef58cc6bd728d4ab2
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S4 (20june)
Issue has been marked resolved - removing QA-Wanted keywords
Keywords: qawanted
(Reporter)

Comment 19

4 years ago
Hi, 

Please see video file attached with the current behaviour in master today's (06/17) buri build:
Gecko-82463f1
Gaia-f93e6fa

For us now it would be ok. But we are confusing about the new bug 1025888 open, what would that bug implies? Is there still anything that need to be changed?
Thanks!
Flags: needinfo?(felash)
(Reporter)

Comment 20

4 years ago
Created attachment 8441221 [details]
Checking the patch in master
In bug 1025888, maybe we can show the phone number earlier. But I don't even know if that's possible.
Flags: needinfo?(felash)
You need to log in before you can comment on or make changes to this bug.