Don't use --enable-trace-malloc on SeaMonkey debug desktop tinderbox builds

RESOLVED FIXED

Status

SeaMonkey
Build Config
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Philip Chee, Assigned: ewong)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1013014 +++
> On TBPL, debug desktop builds are built with --enable-trace-malloc. This means 
> they don't use jemalloc, because TraceMalloc is incompatible with jemalloc. But 
> as far as I know, the TraceMalloc enabling serves no purpose, other than perhaps 
> to provide compile coverage.

See also Thunderbird Bug 1022449
(Assignee)

Comment 1

3 years ago
Created attachment 8436825 [details] [diff] [review]
removed --enable-trace-malloc option from debug mozconfigs.(v1)
Attachment #8436825 - Flags: review?(bugspam.Callek)

Updated

3 years ago
Attachment #8436825 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 2

3 years ago
Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/6a8f85bc2880
Bug 1018039 might also be relevant.
(Assignee)

Comment 4

3 years ago
(In reply to Nicholas Nethercote [:njn] from comment #3)
> Bug 1018039 might also be relevant.

Do we need to add --enable-dmd on our builders?
Flags: needinfo?(bugspam.Callek)
(Assignee)

Comment 5

3 years ago
Comment on attachment 8436825 [details] [diff] [review]
removed --enable-trace-malloc option from debug mozconfigs.(v1)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: no windows build.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #8436825 - Flags: approval-comm-beta?
Attachment #8436825 - Flags: approval-comm-aurora?
(Assignee)

Comment 6

3 years ago
Pushed to comm-beta:
 https://hg.mozilla.org/releases/comm-beta/rev/9e0bc6702db2
(Assignee)

Comment 7

3 years ago
Comment on attachment 8436825 [details] [diff] [review]
removed --enable-trace-malloc option from debug mozconfigs.(v1)

It's already in comm-aurora(due to uplift) and comm-central.
Attachment #8436825 - Flags: approval-comm-aurora?
(Assignee)

Comment 8

3 years ago
Comment on attachment 8436825 [details] [diff] [review]
removed --enable-trace-malloc option from debug mozconfigs.(v1)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: debug builds fail.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #8436825 - Flags: approval-comm-release?

Updated

3 years ago
Attachment #8436825 - Flags: approval-comm-release?
Attachment #8436825 - Flags: approval-comm-release+
Attachment #8436825 - Flags: approval-comm-beta?
Attachment #8436825 - Flags: approval-comm-beta+
Flags: needinfo?(bugspam.Callek)
(Assignee)

Comment 9

3 years ago
Pushed to comm-release:
 https://hg.mozilla.org/releases/comm-release/rev/f29497549d0e
(Assignee)

Comment 10

3 years ago
All three trees have this pushed.  c-c (and c-a from uplift), c-b and recently
c-r.

Closing
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.