[Settings][Wi-Fi] Wi-Fi switcher take long time to be avaiable

RESOLVED DUPLICATE of bug 1009725

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1009725
4 years ago
4 years ago

People

(Reporter: snowmantw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

STR:

1. Open the Wi-Fi panel in Settings app
2. Watch the switcher until it become available
3. It takes about 3 secs to become available.

It would occur when user turn it on and off quickly, too.

Build: 20140604160202
Gaia: 678af023
(Reporter)

Updated

4 years ago
(Reporter)

Updated

4 years ago
Flags: needinfo?(arthur.chen)
Toggling hardwares takes time. Note that the time of the check box being disabled is nearly constant no matter how fast users togging it.

Chuck, can the time of toggling wifi be improved?
Flags: needinfo?(arthur.chen) → needinfo?(chulee)
If the platform doesn't need to unload wifi driver while disable wifi, ignore this step will improve disable/enable time.
But we now default ignore the unload wifi driver step, partner have to add "ro.moz.wifi.unloaddriver=1" to device property to unload wifi driver.

Another possibility is bug 994564, but the disable time doesn't improve on tarako.

Vincent and I are now investigating bug 1009725 to see if there's something delaying the whole progress.

These are all possible work I can think of, but I can't guarantee it can be improved.
Since most of the real work are done by gonk(netutil, wpa_supplicant, wifi driver, etc.), we just send commands.
Flags: needinfo?(chulee)
Thanks for the explanation!
Let's track the issue in one place.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1009725
You need to log in before you can comment on or make changes to this bug.