consider using jsonschema (or something similar) for balrog blobs

RESOLVED DUPLICATE of bug 703040

Status

Release Engineering
Balrog: Backend
P3
normal
RESOLVED DUPLICATE of bug 703040
4 years ago
2 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
We implemented our own schema format/validator for Balrog. It's working OK, but we're starting to stretch its limits in bug 797033, and it doesn't do as detailed of a verification as would be ideal. Nick found https://pypi.python.org/pypi/jsonschema which seems like it would be pretty good for us, at a glance.
(Reporter)

Comment 1

4 years ago
Possible alternative (via ianconnolly): https://github.com/podio/valideer

Might fix bug 1026070 at the same time.
(Reporter)

Comment 2

4 years ago
This might fix bug 703040 if we do it.
(Reporter)

Updated

4 years ago
Priority: -- → P3
(Reporter)

Comment 3

2 years ago
I'm pretty sure this is a dupe of bug 703040, actually...
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 703040
You need to log in before you can comment on or make changes to this bug.