Closed Bug 1022710 Opened 9 years ago Closed 9 years ago

Manual network selection menu disappears after selecting a forbidden network

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S5 (4july)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: brg, Assigned: arthurcc)

References

Details

(Keywords: regression, Whiteboard: [p=2])

Attachments

(1 file)

Tested in master with unagi (Gecko-1a316f5.Gaia-60a0378) and buri (Gecko: 1a316f5.Gaia: deed49c)

Manual network selection menu disappears after selecting manually a forbidden network.
STR:
Settings -> Cellular & Data --> Network Operator
Deactivate Automatic selection to Manual
Wait till the list of available networks is displayed.
Choose any of the forbidden networks available
The network mode menu disappear. YOu must turn off/on the device to make it appear again.

Expected result:
Network mode selection will stay in manual mode and the menu will not disappear.
Triage: QA Wanted to check to see if this happen in 1.4 as well.  We would probably need to move it as a 1.4 blocker if it happens there.
blocking-b2g: 2.0? → 2.0+
Keywords: qawanted
Verified this bug occurs on Flame 1.4. Menu disappears when choosing a forbidden network. However waiting 30+ seconds, the network operator list eventually returns and device does not need to be rebooted. 

Environmental Variables:
Device: Flame 1.4
Build ID: 20140612000202
Gaia: 7fc73d4cb1bece31f50e8ccf6fb98af3984a9ebf
Gecko: bcd308fbbf38
Version: 30.0 (1.4) 
Firmware Version: v10G-2

----------------------------------

This bug does NOT reproduce on Flame 1.3. Operator list remains visible when tapping on a forbidden network.

Environmental Variables:
Device: Flame 1.3
Build ID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3) 
Firmware Version: v10G-2

-------------------------------------------

Verified this bug does occur on Buri v2.0. Menu disappears when choosing a forbidden network. (List did NOT reappear as it did on Flame.)

Environmental Variables:
Device: Buri Master
Build ID: 20140612094656
Gaia: 5e405067230af282a968be69dd00778808679ef5
Gecko: 7dde93e67590
Version: 32.0a2 (Master) 
Firmware Version: v1.2device.cfg

---------------------------------------------

Verified this bug DOES occur on Buri v1.4. Menu disappears when choosing a forbidden network.

Environmental Variables:
Device: Buri 1.4
Build ID: 20140612091532
Gaia: 80bf1039c6ce8bcde57ce06ecb09e40c18c538c6
Gecko: d001f9f42d0d
Version: 30.0 (1.4) 
Firmware Version: v1.2device.cfg

---------------------------------------------

This bug does NOT repro on Buri V1.3. Operator list remains visible when tapping on a forbidden network.

Environmental Variables:
Device: Buri 1.3
Build ID: 20140612002831
Gaia: 20cce4e5dd3ca7dfffc82ce1dce71741dd446952
Gecko: 233d0d0ea774
Version: 28.0 (1.3) 
Firmware Version: v1.2device.cfg
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
QA Contact: croesch
QA-Wanted for Regression Window
Flags: needinfo?(jmitchell)
QA Contact: croesch → pcheng
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Buri
BuildID: 20140409192546
Gaia: d9d689c5ae8003b388e52312712441d355a53cf4
Gecko: de66d4303055
Version: 31.0a1
Firmware Version: v1.2device.cfg

First Broken Environmental Variables:
Device: Buri
Build ID: 20140409210146
Gaia: 8697ff1031861b680140b96badfe37833fd21043
Gecko: 5c0f77e462fc
Version: 31.0a1
Firmware Version: v1.2device.cfg

Last Working Gaia / First Broken Gecko: Issue Does NOT reproduce
Gaia: d9d689c5ae8003b388e52312712441d355a53cf4
Gecko: 5c0f77e462fc

Last Working Gecko / First Broken Gaia: Issue DOES reproduce
Gaia: 8697ff1031861b680140b96badfe37833fd21043
Gecko: de66d4303055

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/d9d689c5ae8003b388e52312712441d355a53cf4...8697ff1031861b680140b96badfe37833fd21043
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
The root cause is that the network selection menu is only displayed when the connected network type is gsm. Maybe we should keep the original visibility when the connected network type becomes null or unknown.
Broken by bug 949741 - present on 1.4, so moving to 1.4?
Blocks: 949741
blocking-b2g: 2.0+ → 1.4?
blocking-b2g: 1.4? → 1.4+
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Arthur, please redirect this bug to the team.
Flags: needinfo?(arthur.chen)
Assignee: nobody → arthur.chen
Flags: needinfo?(arthur.chen)
Whiteboard: [p=2][ETA: 6/24]
Hi EJ, could you help review this tiny patch? Thanks!
Attachment #8443400 - Flags: review?(ejchen)
Comment on attachment 8443400 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/20792

looks nice to me ! Thanks Arthur :P
Attachment #8443400 - Flags: review?(ejchen) → review+
Thanks, EJ!

master: 456040e4c4d0bb5e4213783c54cea663266096be
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Thanks for the fix! I have tested master with hamachi- Gecko-fda21c3.Gaia-ed5231f (today build) and the manual network selection is shown after the user selects a forbidden network.
You need to log in before you can comment on or make changes to this bug.