Closed Bug 1022784 Opened 6 years ago Closed 6 years ago

Fix warnings about AutoGCRooter attribute inconsistencies

Categories

(Core :: JavaScript: GC, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
firefox32 --- fixed
firefox33 --- fixed

People

(Reporter: Waldo, Assigned: Waldo)

Details

Attachments

(1 file)

Similar to bug 1021001, but this seems to only be a warning, not an error.  I guess the definition usually gets seen before the declaration.
Attached patch PatchSplinter Review
Attachment #8437050 - Flags: review?(terrence)
Comment on attachment 8437050 [details] [diff] [review]
Patch

Review of attachment 8437050 [details] [diff] [review]:
-----------------------------------------------------------------

Shame to have to move the full def to jspubtd.h, but given how messed this whole situation already is I'm fine with it.
Attachment #8437050 - Flags: review?(terrence) → review+
Comment on attachment 8437050 [details] [diff] [review]
Patch

https://hg.mozilla.org/integration/mozilla-inbound/rev/ecbee0ea949e

This is an easy warning fix that will make make building on this branch, and ensuring backports don't introduce warnings, easier for its lifetime.  This early in the cycle I don't see a reason not to do it.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): unknown
User impact if declined: aurora build will be a bit warningy for gcc builders
Testing completed (on m-c, etc.): landed on m-i, built/tested with clang and gcc both locally, unified/non-unified modes both
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: N/A
Attachment #8437050 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/ecbee0ea949e
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Comment on attachment 8437050 [details] [diff] [review]
Patch

I'm good with taking this cleanup in the first couple weeks of Aurora. Approved.
Attachment #8437050 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.