tp5o_shutdown_paint test unusably noisy

RESOLVED FIXED

Status

Testing
Talos
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: vladan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Starting around November, the noise band for the tp5o_shutdown_paint shutdown-time test has increased manifold, almost to the point of being meaningless.

http://graphs.mozilla.org/graph.html#tests=[[273,94,25]]&sel=none&displayrange=365&datatype=running
(Reporter)

Comment 1

3 years ago
Looks like this was discussed back in November but never acted on(?) https://groups.google.com/forum/#!msg/mozilla.dev.tree-management/r9iehVDynmM/zKdgu0lhkeAJ

Comment 2

3 years ago
FWIW, I've noticed that recently (though probably later than November) shotdown times seems quite random, _sometimes_ with addon-manager related errors on the console during shotdown. I don't know if these are related, however.
(Reporter)

Updated

3 years ago
Blocks: 1004427
(Reporter)

Updated

3 years ago
No longer blocks: 1004427
this became a problem when we switch our process management from the old bcontroller.py method to using mozprocess.  The motivating factor there was to fix a large common crash in dromaeo on windows- we did that and haven't had any problems since, but this shutdown stuff is a fall out from it :(
Duplicate of this bug: 934447
we don't run this test anymore, if we do wish to do it, I would prefer a new bug be opened up.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.