[flatfish] [Browser] Bookmarks are not added to the homescreen

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: gaby2300, Assigned: raghav, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Flatfish][TCP][good first bug])

(Reporter)

Description

4 years ago
Bookmarks are not saved in the home screen using my Firefox OS 2.0 tablet

1. Open the browser
2. Browse to a site
3. Tap the white star in the lower side of the screen.
4. Tap Add to home screen
5. Go to the home screen
6. Notice the bookmark hasn't been added

Actual result: the bookmark hasn't been added to the home screen
Expected result: the bookmark should be added to the home screen
(Reporter)

Comment 1

4 years ago
This issue exists using the latest 2.1 stable build as well.

Updated

4 years ago
Whiteboard: [Flatfish]

Updated

4 years ago
Blocks: 903304

Updated

4 years ago
Whiteboard: [Flatfish] → [Flatfish][TCP]
Whiteboard: [Flatfish][TCP] → [Flatfish][TCP][good first bug]
I can confirm this bug on my device running the latest July 25th build.
Assignee: nobody → kondapallirr
Hi :maitreya, 

This is mostly applist issue, a good start for contributors,
if your are interested in this bug I would glad to mentor this.
Flags: needinfo?(abhiram)
Hi Chens,

> This is mostly applist issue, a good start for contributors,  
> if your are interested in this bug I would glad to mentor this.

Great! I can certainly use some help on this.
Flags: needinfo?(abhiram)
Mentor: shchen
(In reply to Sherman Chen [:chens] from comment #3)
> Hi :maitreya, 
> 
> This is mostly applist issue, a good start for contributors,
> if your are interested in this bug I would glad to mentor this.

Chens, 

The bug was not present in 1.4 and after that is present in all the tablet versions. As for the applist part, can you tell me where I should start looking?
You can find details about applist on MDN [1].
For tablet's app list you can find it in /build/config/tablet/apps-*.list

[1]: https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/Customizing_build-time_apps
Depends on: 1051672
Fixed since bug 1051672 landed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 8

4 years ago
The issue is resolved with a TCP build from today's master.
Verified okay on my Flatfish.

OS version:2.1.0.0-prerelease
BuildID: 20140813012313
Gaia: 72bb113df0d50e179925e1ad33d6b811559331aa
Gecko:05976976d9d413d8288ac6b2f9933732552d89bf
Version: 34.0a1

Updated

4 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

4 years ago
I can verify this bug is fixed in the August 15 FFOS 2.1 build.
You need to log in before you can comment on or make changes to this bug.