FMD Doesn't Always Show as 'Enabled' in Settings Even When It Is

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
FindMyDevice
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: Kate Glazko, Assigned: ggp)

Tracking

unspecified
2.0 S4 (20june)
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8437354 [details]
Enabled Absent from Settings After Restart

This typically happens after a phone restart. After restarting phone, head to Settings. You will see Find My Device under Account Management, and there will be no disabled nor enabled text under 'Find My Device'.

When you click on FMD, if it is enabled as it was in my case, you will see that it is enabled with the blue toggle bar. However, it will flash the sign in screen for about a minute before showing the toggle bar.

When you go back to the settings, Enabled will display as it is supposed to. If you lock the phone and head to Settings, enabled will show.

Summary: After a restart, Enabled/Disabled text doesn't show in the menu. I have attached a video to demonstrate.
(Reporter)

Updated

4 years ago
QA Contact: kglazko
(Assignee)

Comment 1

4 years ago
Created attachment 8438733 [details] [review]
gaia pull request
Attachment #8438733 - Flags: review?(21)
Assignee: nobody → ggoncalves

Updated

4 years ago
Target Milestone: --- → 2.0 S4 (20june)

Updated

4 years ago
blocking-b2g: --- → 2.0?

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
(Assignee)

Comment 2

4 years ago
Comment on attachment 8438733 [details] [review]
gaia pull request

:arthurcc may be a better reviewer for this, we don't want to overwhelm :vintgetun.
Attachment #8438733 - Flags: review?(21) → review?(arthur.chen)
Comment on attachment 8438733 [details] [review]
gaia pull request

Thank you for the patch, Guilherme! As we were refactoring settings app using AMD pattern, could you write the newly added code an AMD module in root/ and include it in root/panel.js?

The module would take a dom element as the parameter and be enabled/disabled at the right time. Please refer to root/battery_item.js for details.
Attachment #8438733 - Flags: review?(arthur.chen)
(Assignee)

Comment 4

4 years ago
Comment on attachment 8438733 [details] [review]
gaia pull request

Updated the PR. Thanks for the feedback, Arthur. Let me know if I missed anything!
Attachment #8438733 - Flags: review?(arthur.chen)
Comment on attachment 8438733 [details] [review]
gaia pull request

Looks much better! Please check my comments in github, thanks!
Attachment #8438733 - Flags: review?(arthur.chen)
(Assignee)

Comment 6

4 years ago
Updated the PR to address the comments. I haven't changed the hidden element change because I was hoping to piggyback that fix in this bug (see my response on GitHub for details, please), but the other comments have been fixed.
(Assignee)

Updated

4 years ago
Attachment #8438733 - Flags: review?(arthur.chen)
Comment on attachment 8438733 [details] [review]
gaia pull request

r=me, please squash the commits before merging, thanks.
Attachment #8438733 - Flags: review?(arthur.chen) → review+
(Assignee)

Comment 8

4 years ago
Done, thank you!
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Gaia-try tests look good, merging.

Master: https://github.com/mozilla-b2g/gaia/commit/6bf7dc1a2d7f6eef651d6e4932fae8e7d70a27dd
Keywords: checkin-needed
(Reporter)

Comment 10

4 years ago
Needs uplifting..
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

4 years ago
Comment on attachment 8438733 [details] [review]
gaia pull request

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1022992
[User impact] if declined: Little impact, this is mostly UI polishing
[Testing completed]: Travis and manual.
[Risk to taking this patch] (and alternatives if risky): None.
[String changes made]: None.
Attachment #8438733 - Flags: approval-gaia-v2.0?(bbajaj)
(Assignee)

Comment 12

4 years ago
No need to reopen, though.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
https://tbpl.mozilla.org/?tree=Gaia-Try&rev=a4d568cd4ec2dc900e1b112e428da4aa8c1ab57b

master: 10729f6795fc6e4fad957e4e69d79a945323713c
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
I meant 2.0: 10729f6795fc6e4fad957e4e69d79a945323713c
Comment on attachment 8438733 [details] [review]
gaia pull request

Already landed in 2.0, cleaning the flag up..
Attachment #8438733 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
Issue does not repro, after restarting multiple times, "Enabled" is always shown on the Settings menu.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140630000201
Gaia: c0c8ad187c0466285f2580531e09f8322996f561
Gecko: d4dc609bcc8a
Version: 32.0a2 (2.0)
Firmware Version: v122

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: RESOLVED → VERIFIED

Updated

4 years ago
status-b2g-v2.0: fixed → verified
Created attachment 8530716 [details]
Verify_Video_Flame2.1.MP4

This issue has been verified successfully on Flame 2.1.

Steps:
1.Sign in Firefox account in Settings.
2.Restart device and check enabled text under 'Find My Device'.
** Enabled text under 'Find My Device' is shown.

Note: Restart device without the firefox account, The disabled text under 'Find My Device' is shown normally.
See attachment: Verify_Video_Flame2.1.MP4
Reproducing rate: 0/10

Flame v2.1 version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141130001203
Version         34.0
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.