[Settings][Ringtone][V2.0] The "<" icon of sound settings page becomes "X" icon after back from ringtone app

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Ringtones
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: rudyl, Assigned: rudyl)

Tracking

unspecified
2.0 S4 (20june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 verified)

Details

(Whiteboard: interaction-design [LibGLA,Dev, B])

Attachments

(2 attachments)

+++ This bug was initially created as a clone of Bug #1016280 +++

STR
===
* Reproduction steps:
  1. Launch the settings app then tap "Sounds"
  2. Click "Manage Ringtones".
  3. Tap "<" to go to previous page
  4. Checking the "<" icon on sound settings page

* Expected result:
  The "<" icon is at the top-left corner

* Actual result:
  The "<" icon became "X" icon.
User Story: (updated)
Component: Gaia::Settings → Gaia::Ringtones
Created attachment 8437422 [details] [review]
Patch V1 - pull request 20259

I have a patch to remove the 'section' when invoking settings app activity.

Jim,

Could you please review this?
Thank you.
Attachment #8437422 - Flags: review?(squibblyflabbetydoo)

Comment 2

4 years ago
Comment on attachment 8437422 [details] [review]
Patch V1 - pull request 20259

Based on the changes to the keyboard app in bug 1016280, this looks good to me!
Attachment #8437422 - Flags: review?(squibblyflabbetydoo) → review+
Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/e0c637f14265291ed81934058ec1cc019612127c

--
Jim, thanks for the review.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Assignee: nobody → rlu

Comment 4

4 years ago
incorrect and mis-leading navigation control, so adding to 2.0 blocker
blocking-b2g: --- → 2.0+
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S4 (20june)
Whiteboard: interaction-design

Comment 6

4 years ago
Good Job! Thanks everyone.
I cannot reproduce it.

* Build information:
 - Gaia      0f254c92bc44d614ae56a855f18a895a7e4703ad
 - Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/301e62e44f18
 - BuildID   20140616160201
 - Version   32.0a2
Status: RESOLVED → VERIFIED

Updated

4 years ago
Whiteboard: interaction-design → interaction-design [LibGLA,Dev, B]

Updated

4 years ago
status-b2g-v2.1: fixed → verified

Comment 7

4 years ago
Created attachment 8528879 [details]
VIDEO0050.mp4

This issue has been successfully verified on Flame 2.1:
Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
Build-ID        20141125001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
You need to log in before you can comment on or make changes to this bug.