(2.1-visual-refresh)[Notifications and Alarms] - Add New Tones

RESOLVED DUPLICATE of bug 1046399

Status

Firefox OS
Gaia::Ringtones
P2
normal
RESOLVED DUPLICATE of bug 1046399
4 years ago
4 years ago

People

(Reporter: ivanovpavel, Assigned: ivanovpavel)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(feature-b2g:2.1)

Details

Attachments

(2 attachments)

+++ This bug was initially created as a clone of Bug #1014009 +++

For the visual design refresh we have created a new set of ringtones to better reflect the visual style. These cover:
+ ringtones
+ alarms
+ message notifications

1. The WAV files are here: https://mozilla.box.com/s/6x15jupkdv98qbrrsgpy they need to be compressed. 
2. Current tones need to be replaced within the OS.
Priority: -- → P2
Depends on: 1023134
No longer depends on: 1014009
Created attachment 8437542 [details] [review]
patch for Gaia/master
Attachment #8437542 - Flags: feedback?(padamczyk)
Created attachment 8437954 [details]
Screenshot from the notification selection screen.

Pavel you need to name the notifications somewhere, just like the old set. Just use the file name. ie:
"notifier_bells.ogg" will be named: "bells"
Attachment #8437542 - Flags: feedback?(padamczyk) → feedback-
Hey Patryk,
I made the changes ... and I think that this works now
Summary: (2.0-visual-refresh)[Notifications] - Add New Tones → (2.0-visual-refresh)[Notifications and Tones] - Add New Tones
Duplicate of this bug: 1023134
Summary: (2.0-visual-refresh)[Notifications and Tones] - Add New Tones → (2.0-visual-refresh)[Notifications and Alarms] - Add New Tones
Comment on attachment 8437542 [details] [review]
patch for Gaia/master

Now my PR contains needed changes for Notifications and Alarms and looks ok on my hamachi
Attachment #8437542 - Flags: feedback- → feedback?(padamczyk)
Its still broken on the flame... Same error :(
Comment on attachment 8437542 [details] [review]
patch for Gaia/master

Do you have a flame yet? Are you getting the same 
"make: *** [operatorvariant] Error 3" error I am getting?
Attachment #8437542 - Flags: feedback?(padamczyk) → feedback-
Flags: needinfo?(pivanov)
not yet ... I expect it soon ... but I don't have such problems with my hamachi ... I will ping you back when I receive the flame and when I test the patch with it
Flags: needinfo?(pivanov)
Alias: Ringtones
Alias: Ringtones
Comment on attachment 8437542 [details] [review]
patch for Gaia/master

Hey Patryk,

can you check it again with the steps who I send you on the email. I think I found the problem and I fixed it (I have a flame now and I have a chance to test this patch)
Attachment #8437542 - Flags: feedback- → feedback?(padamczyk)
Attachment #8437542 - Flags: review?(clee)
Comment on attachment 8437542 [details] [review]
patch for Gaia/master

Looks good! Push them in.
Attachment #8437542 - Flags: review?(clee)
Attachment #8437542 - Flags: feedback?(padamczyk)
Attachment #8437542 - Flags: feedback+
Attachment #8437542 - Flags: review?(dflanagan)
Comment on attachment 8437542 [details] [review]
patch for Gaia/master

Jim, could you take this review please?
Attachment #8437542 - Flags: review?(dflanagan) → review?(squibblyflabbetydoo)
It looks like this bug is marked confidential becasue it was cloned from a confidential bug. Is there any reason it needs to be marked that way?
Flags: needinfo?(padamczyk)

Comment 13

4 years ago
Comment on attachment 8437542 [details] [review]
patch for Gaia/master

This looks mostly good, but we're probably going to want a migration step when we upgrade. What if the user has picked a default notification sound that we've removed? It'll probably still play the old notification until they change it manually. We need to decide what to do here; maybe reset everyone's notification sound to the factory default?
Attachment #8437542 - Flags: review?(squibblyflabbetydoo) → review-

Comment 14

4 years ago
Also, I can't review the clock changes, so you'll need to find someone from productivity to take a look at that.
Group: mozilla-employee-confidential
Flags: needinfo?(padamczyk)
Hey Patryk,
what do you think about Jim's comment?

Comment 16

4 years ago
This needs r+ and is too late for 2.1. If we think this is critical to get in for 2.0, let me know, but it really is too late.
feature-b2g: --- → 2.1
Blocks: 1046324
No longer blocks: 930561, 1014009
Summary: (2.0-visual-refresh)[Notifications and Alarms] - Add New Tones → (2.1-visual-refresh)[Notifications and Alarms] - Add New Tones
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1046399
No longer blocks: 1046324
You need to log in before you can comment on or make changes to this bug.