Closed Bug 1023232 Opened 7 years ago Closed 6 years ago

[highlighter] Box-model highlighter doesn't work with multi-line inline boxes

Categories

(DevTools :: Inspector, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1139925

People

(Reporter: pbro, Unassigned)

Details

STR:

- open this page:
data:text/html,<div style='width:10px;'><span style='transform:translate(100px)'>text that wraps</span></div>
- inspect the span

==> The box-model highlighter only draws a rectangle around the first line box.

That's because in our getBoxQuads() wrapper: http://mxr.mozilla.org/mozilla-central/source/toolkit/devtools/LayoutHelpers.jsm#40 we only care about the first quad returned.

2 solutions:
- either we calculate the outer bounds by using the min/max values found in all quads returned
- or we create a new InlineBoxHighlighter specifically for inline elements that would draw as many rectangles on the page as there are line boxes (with padding/margin and all)
(In reply to Patrick Brosset [:pbrosset] [:patrick] from comment #0)
> - or we create a new InlineBoxHighlighter specifically for inline elements
> that would draw as many rectangles on the page as there are line boxes (with
> padding/margin and all)
which could be part of meta bug 942176
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1139925
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.