Closed Bug 1023311 Opened 6 years ago Closed 6 years ago

translation.manifest needs to be packaged

Categories

(Firefox :: Translation, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 33
Tracking Status
firefox32 --- verified
firefox33 --- verified

People

(Reporter: Felipe, Assigned: Felipe)

Details

(Whiteboard: p=2 s=33.1 [qa!])

Attachments

(1 file)

This file declares the FHR provider for translation. It works locally but not on packaged builds because the manifest file was missing.
Attachment #8437698 - Flags: review?(benjamin)
Flags: firefox-backlog+
Attachment #8437698 - Flags: review?(benjamin) → review+
https://hg.mozilla.org/integration/fx-team/rev/4c12cd6eee61

Marco, please add this bug to the current iteration.
Flags: needinfo?(mmucci)
Added to Iteration 33.1
Flags: needinfo?(mmucci)
Whiteboard: [p=2] [qa+] → [p=2] s=33.1 [qa+]
https://hg.mozilla.org/mozilla-central/rev/4c12cd6eee61
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Whiteboard: [p=2] s=33.1 [qa+] → p=2 s=33.1 [qa+]
QA Contact: bogdan.maris
Comment on attachment 8437698 [details] [diff] [review]
Package translation.manifest

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This bug is part of the automatic translation feature, which we want to A/B with a subset of Aurora 32 users.
User impact if declined: Important data for the A/B test won't be collected due to the translation's FHR provider not being registered correctly
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): minimal
String or IDL/UUID changes made by this patch: none
Attachment #8437698 - Flags: approval-mozilla-aurora?
I tested on latest Nightly to see if FHR properly records translation data. I encountered a potential issue there:
1. Start Firefox.
2. Change 'toolkit.telemetry.enabled' value to 'false'
3. Change 'browser.translation.detectLanguage' and 'browser.translation.ui.show' values to 'true'
4. Restart Firefox
5. Check FHR (No telemetry data is recorded)
6. Change 'toolkit.telemetry.enabled' value to 'true'
7. Check FHR ("detectLanguageEnabled": 0 and "showTranslationUI": 0)

Notes:
 The translation works as expected 
"translationOpportunityCount" and "translationOpportunityCountsByLanguage" have values different from 0.
 I noticed that toggling with toolkit.telemetry.enabled does not need a restart only a refresh of FHR. Though if I restart the browser the value of prefs from step 7 turn to '1' (true).

Is this the intended behavior?
Flags: needinfo?(felipc)
Thanks for the investigation. I can't reproduce that exactly but I can see some odd behaviors while toggling toolkit.telemetry.enabled. I think this is due to how the types of fhr data (daily, counter, etc) are collected.

It might be worth filing that as a separate bug to see if there's anything that should be done there, but it is unrelated to this bug fix which was about making sure the provider exists in packaged builds.
Flags: needinfo?(felipc)
Thanks Felipe, I logged bug 1025794 on that, also marking this bug verified fixed based on my testing on Windows 7 64bit, Ubuntu 13.04 64bit, Mac OS X 10.9.3 using latest Nightly.
Status: RESOLVED → VERIFIED
Whiteboard: p=2 s=33.1 [qa+] → p=2 s=33.1 [qa!]
Attachment #8437698 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Also verified on Windows 7 64bit, Mac OS X 10.9.3 and Ubuntu 13.04 64bit using latest Aurora.
You need to log in before you can comment on or make changes to this bug.