Use touch events instead of mouse events for the browser app

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: vingtetun, Assigned: daleharvey)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Bug 1005815 will disable mouse events coming along with touch events in the system app. This is a broken behavior on a touch device that is here more or less since the first day of touch events in Gaia.

As a result some of our code rely on this broken behavior.
Apologies for the delay, was offline most of last week

Pushed a travis run @ https://github.com/mozilla-b2g/gaia/pull/20587 although given the state of our browser integration test, I doubt that will be a problem
Comment on attachment 8437764 [details] [diff] [review]
touchstart.browser

Review of attachment 8437764 [details] [diff] [review]:
-----------------------------------------------------------------

This is looking good, thanks, will push when I see green
Attachment #8437764 - Flags: review?(dale) → review+
Failing ui test, will take and fix
Assignee: nobody → dale
Duplicate of this bug: 876411
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.