Intermittent localization_test.js | Vertical - Localization Localization updates icon names

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Homescreen
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jgriffin, Assigned: kgrandon)

Tracking

({intermittent-failure})

unspecified
2.0 S4 (20june)
intermittent-failure
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

(Whiteboard: [p=1],[systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
07:38:02     INFO -  TEST-START | Vertical - Localization Localization updates icon names
07:38:21     INFO -  TEST-UNEXPECTED-FAIL | /builds/slave/test/gaia/apps/verticalhome/test/marionette/localization_test.js | Vertical - Localization Localization updates icon names
07:38:21     INFO -  TEST-END | Vertical - Localization Localization updates icon names

https://tbpl.mozilla.org/php/getParsedLog.php?id=41447300&tree=B2g-Inbound&full=1
(Reporter)

Updated

4 years ago
Keywords: intermittent-failure
QA Whiteboard: [VH-FC-blocking-]
Kevin - This is the key blocker right now to why gaia integration tests are hidden on TBPL. Can you find someone to look into this or redirect to someone who can fix this?
Flags: needinfo?(kgrandon)

Updated

4 years ago
Blocks: 989848
(Assignee)

Comment 2

4 years ago
Oh sure, we actually had a patch for this that I believe got backed out of another bug. The fix for this isn't too bad.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Flags: needinfo?(kgrandon)
(Assignee)

Comment 3

4 years ago
Created attachment 8438017 [details] [review]
Github pull request

James - I think you fixed this, but I'm not sure where. Should we land this?
Attachment #8438017 - Flags: review?(jlal)
(Assignee)

Updated

4 years ago
Whiteboard: [p=1],[systemsfe]
Target Milestone: --- → 2.0 S4 (20june)
(Assignee)

Comment 4

4 years ago
Comment on attachment 8438017 [details] [review]
Github pull request

Got a r+ from James over IRC.
Attachment #8438017 - Flags: review?(jlal) → review+
(Assignee)

Comment 5

4 years ago
Looking very green on travis, and previously not as healthy: https://travis-ci.org/KevinGrandon/gaia/builds/27264072 

I think we can land this.
(Assignee)

Comment 6

4 years ago
Landed: https://github.com/mozilla-b2g/gaia/commit/fca906183e6fae9463119a5fde3e397fcb9a6f5c
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

4 years ago
Comment on attachment 8438017 [details] [review]
Github pull request

This is needed for the vertical homescreen. We've put forward a best effort to believe that this is safe for uplift and the tree will remain green.
Attachment #8438017 - Flags: approval-gaia-v2.0?(bbajaj)

Updated

4 years ago
Attachment #8438017 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
(Assignee)

Comment 8

4 years ago
Uplifted: https://github.com/mozilla-b2g/gaia/commit/45f66fcf29ac1960d63862594c06bdd776bf45ab
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Comment hidden (Treeherder Robot)
Hi Jonathan,

Could you please provide the detailed reproduce steps or video for me to verify this bug?
Thank you very much!
Flags: needinfo?(jgriffin)
(Assignee)

Comment 11

4 years ago
This looks like a test only issue. It's pretty clear from the bug title/description. No verification should be necessary.
Flags: needinfo?(jgriffin)
You need to log in before you can comment on or make changes to this bug.