Intermittent browser_image.js | application crashed [@ js::gc::IsAboutToBeFinalized<js::UnownedBaseShape>] after "Assertion failure: *thingp, at js/src/gc/Marking.cpp:376"

RESOLVED DUPLICATE of bug 1010666

Status

()

RESOLVED DUPLICATE of bug 1010666
5 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({assertion, crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=41460142&tree=Mozilla-Aurora

Rev4 MacOSX Snow Leopard 10.6 mozilla-aurora debug test mochitest-browser-chrome-2 on 2014-06-10 11:45:13 PDT for push a48d663e71b2
slave: t-snow-r4-0058

11:50:40     INFO -  TEST-PASS | chrome://mochitests/content/browser/image/test/browser/browser_image.js | Must have animated once out of bfcache!
11:50:40     INFO -  TEST-PASS | chrome://mochitests/content/browser/image/test/browser/browser_image.js | Must have also animated the background image, and essentially the same # of frames. Regular image got 45 frames but background image got 44
11:50:40     INFO -  [965] WARNING: NS_ENSURE_TRUE(mMutable) failed: file /builds/slave/m-aurora-osx64-d-0000000000000/build/netwerk/base/src/nsSimpleURI.cpp, line 265
11:50:41     INFO -  ++DOCSHELL 0x11b6a5800 == 14 [pid = 965] [id = 316]
11:50:41     INFO -  ++DOMWINDOW == 34 (0x11fe9d000) [pid = 965] [serial = 859] [outer = 0x0]
11:50:41     INFO -  ++DOMWINDOW == 35 (0x123d88800) [pid = 965] [serial = 860] [outer = 0x11fe9d000]
11:50:41     INFO -  [965] WARNING: NS_ENSURE_TRUE(mMutable) failed: file /builds/slave/m-aurora-osx64-d-0000000000000/build/netwerk/base/src/nsSimpleURI.cpp, line 265
11:50:41     INFO -  TEST-KNOWN-FAIL | chrome://mochitests/content/browser/image/test/browser/browser_image.js | uncaught exception: uncaught exception: [object StopIteration] at :0
11:50:41     INFO -  JavaScript error: , line 0: uncaught exception: [object StopIteration]
11:50:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/image/test/browser/browser_image.js | Console message: [JavaScript Error: "uncaught exception: [object StopIteration]"]
11:50:41     INFO -  ++DOMWINDOW == 36 (0x12a277800) [pid = 965] [serial = 861] [outer = 0x11fe9d000]
11:50:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/image/test/browser/browser_image.js | Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.com/browser/image/test/browser/image.html" line: 0}]
11:50:42     INFO -  ++DOCSHELL 0x119e9b800 == 15 [pid = 965] [id = 317]
11:50:42     INFO -  ++DOMWINDOW == 37 (0x11d4bf400) [pid = 965] [serial = 862] [outer = 0x0]
11:50:42     INFO -  ++DOMWINDOW == 38 (0x123db4400) [pid = 965] [serial = 863] [outer = 0x11d4bf400]
11:50:42     INFO -  [965] WARNING: NS_ENSURE_TRUE(mMutable) failed: file /builds/slave/m-aurora-osx64-d-0000000000000/build/netwerk/base/src/nsSimpleURI.cpp, line 265
11:50:42     INFO -  ++DOMWINDOW == 39 (0x1259ec800) [pid = 965] [serial = 864] [outer = 0x11d4bf400]
11:50:43     INFO -  TEST-INFO | chrome://mochitests/content/browser/image/test/browser/browser_image.js | Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.com/browser/image/test/browser/imageX2.html" line: 0}]
11:50:43     INFO -  Assertion failure: *thingp, at /builds/slave/m-aurora-osx64-d-0000000000000/build/js/src/gc/Marking.cpp:376
11:50:45     INFO -  TEST-INFO | Main app process: killed by SIGHUP
11:50:45  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/image/test/browser/browser_image.js | application terminated with exit code 1
11:50:45     INFO -  INFO | runtests.py | Application ran for: 0:03:34.898686
11:50:45     INFO -  INFO | zombiecheck | Reading PID log: /var/folders/gp/gp6E0Yo7GAOF8RNmVxgKMU+++-k/-Tmp-/tmp5ZdiDNpidlog
11:51:06  WARNING -  PROCESS-CRASH | chrome://mochitests/content/browser/image/test/browser/browser_image.js | application crashed [@ js::gc::IsAboutToBeFinalized<js::UnownedBaseShape>]
11:51:06     INFO -  Crash dump filename: /var/folders/gp/gp6E0Yo7GAOF8RNmVxgKMU+++-k/-Tmp-/tmpttTtJC/minidumps/55A9F43A-A021-4A30-B993-3C28A777E2AE.dmp
11:51:06     INFO -  Operating system: Mac OS X
11:51:06     INFO -                    10.6.8 10K549
11:51:06     INFO -  CPU: amd64
11:51:06     INFO -       family 6 model 23 stepping 10
11:51:06     INFO -       2 CPUs
11:51:06     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
11:51:06     INFO -  Crash address: 0x0
11:51:06     INFO -  Thread 0 (crashed)
11:51:06     INFO -   0  XUL!js::gc::IsAboutToBeFinalized<js::UnownedBaseShape> [Marking.cpp:a48d663e71b2 : 375 + 0x0]
11:51:06     INFO -      rbx = 0x00007fff710922f8   r12 = 0x00007fff5fbfcc40
11:51:06     INFO -      r13 = 0x00007fff5fbfcd18   r14 = 0x0000000000000000
11:51:06     INFO -      r15 = 0x00007fff5fbfcc38   rip = 0x00000001047475b4
11:51:06     INFO -      rsp = 0x00007fff5fbfcc00   rbp = 0x00007fff5fbfcc10
11:51:06     INFO -      Found by: given as instruction pointer in context
11:51:06     INFO -   1  XUL!js::gc::IsBaseShapeAboutToBeFinalized(js::UnownedBaseShape**) [Marking.cpp:a48d663e71b2 : 496 + 0x4]
11:51:06     INFO -      rbx = 0x000000015484f6f8   r12 = 0x00007fff5fbfcc40
11:51:06     INFO -      r13 = 0x00007fff5fbfcd18   r14 = 0x00000001188df5d0
11:51:06     INFO -      r15 = 0x00007fff5fbfcc38   rip = 0x00000001047473b9
11:51:06     INFO -      rsp = 0x00007fff5fbfcc20   rbp = 0x00007fff5fbfcc20
11:51:06     INFO -      Found by: call frame info
11:51:06     INFO -   2  XUL!JSCompartment::sweepBaseShapeTable() [Shape.cpp:a48d663e71b2 : 1535 + 0x7]
11:51:06     INFO -      rbx = 0x000000015484f6f8   r12 = 0x00007fff5fbfcc40
11:51:06     INFO -      r13 = 0x00007fff5fbfcd18   r14 = 0x00000001188df5d0
11:51:06     INFO -      r15 = 0x00007fff5fbfcc38   rip = 0x0000000104c13cd9
11:51:06     INFO -      rsp = 0x00007fff5fbfcc30   rbp = 0x00007fff5fbfcca0
11:51:06     INFO -      Found by: call frame info
11:51:06     INFO -   3  XUL!JSCompartment::sweep(js::FreeOp*, bool) [jscompartment.cpp:a48d663e71b2 : 597 + 0x7]
11:51:06     INFO -      rbx = 0x00007fff5fbfcd58   r12 = 0x00000001188df000
11:51:06     INFO -      r13 = 0x00007fff5fbfcd18   r14 = 0x00000001188df5d0
11:51:06     INFO -      r15 = 0x0000000123138800   rip = 0x0000000104a3a149
11:51:06     INFO -      rsp = 0x00007fff5fbfccb0   rbp = 0x00007fff5fbfcce0
11:51:06     INFO -      Found by: call frame info
11:51:06     INFO -   4  XUL!js::gc::GCRuntime::beginSweepingZoneGroup() [jsgc.cpp:a48d663e71b2 : 3982 + 0x11]
11:51:06     INFO -      rbx = 0x0000000123138800   r12 = 0x0004fb7fce120f10
11:51:06     INFO -      r13 = 0x00007fff5fbfcd18   r14 = 0x0000000000000010
11:51:06     INFO -      r15 = 0x00000001188df5d0   rip = 0x0000000104a70c17
11:51:06     INFO -      rsp = 0x00007fff5fbfccf0   rbp = 0x00007fff5fbfcd90
11:51:06     INFO -      Found by: call frame info
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1010666
You need to log in before you can comment on or make changes to this bug.