Several separators make mails hardly readable.

VERIFIED DUPLICATE of bug 102165

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 102165
16 years ago
13 years ago

People

(Reporter: Simon Spiegel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4+) Gecko/20010928
BuildID:    2001092803

If a mail has "--" as signature separator, Mozilla greys the signature. While
this is quite nice, it gets really irritating when a mail has several
separators. This happens for example with digests of mailing lists which contain
several mails. Once a mail with a "--" separator appears the rest of the whole
mail becomes grey regardless that other mails follow.

Reproducible: Always
Steps to Reproduce:
1. Write a mail with a "--" signature separator.
2. Add a second mail to the first.
3. There you go.

Actual Results:  Everything below "--" gets grey.

Expected Results:  I don't exactly know how this can be achieved, but Mozilla
should be able to recognise mails that consist of several mails and be able to
set font color back to black after the signature.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 102165 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED

Comment 3

16 years ago
Simon, are you still seeing this with nightly builds.  
I know this was marked as a dup, but I can't reproduce the dup based on what I
thought was a scenario since there were no steps to reproduce.  So I read your
scenario and I can't reproduce this one either.  The build I used was 20011218
on windows plain text compose with reply and forward.  Reply doesn't show
previous signatures, does show all the text from all the replys.  Forwarding
does show all the signatures from all the forwarded messages in grey but the msg
body is no grey. 
At this point if you don't see the problem bug 54570 is still a problem we may
have separate bugs.
(Reporter)

Comment 4

16 years ago
Sorry, I think you didn't undertstand what this bug is about. Tt's not about
replying, it's about mailing lists and the like. If you have several mails in a
row (which often happens in mailing lists - especially in digests) - the mails
get hardly reabable after the first separator. So, yes, this is a dup and I
still see this in current builds. Mozilla shoud be somehow able to recognise the
end of a sig or the beginning of a new mail and change color from grey to black
again.

Comment 5

16 years ago
Thanks for the info
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.