Closed Bug 1023644 Opened 6 years ago Closed 3 years ago

Setup tooltool on SeaMonkey Win32 builders and update the other platform's tooltool setup

Categories

(SeaMonkey :: Build Config, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ewong, Assigned: ewong)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files, 6 obsolete files)

No description provided.
Mike, if you recall bug(s) that did this for moco can you please link the up here?

Specifically tooltool script addition/deploy, the mozmake stuff, and the stuff thats breaking pymake.
Assignee: nobody → bugspam.Callek
bug 980120 is the tooltool deployment for m-c and tb windows builds.
bug 1021538 is switching to mozmake for c-c (nothing else is needed to switch to mozmake as long as tooltool is up)
bug 921313 or a variant of it is what i expect will break building with pymake.
This is just for the tools/ folder.  (from Callek's user's tool repo)
Attachment #8443855 - Flags: review?(bugspam.Callek)
Attached patch Buildbot-configs patch (v1) (obsolete) — Splinter Review
Attachment #8443861 - Flags: review?(bugspam.Callek)
Is this bug the reason that there are no windows trunk builds since June 13th or is there something else that needs to be fixed?
(In reply to Sven Grull from comment #5)
> Is this bug the reason that there are no windows trunk builds since June
> 13th or is there something else that needs to be fixed?

Yes. tooltool needs to be setup on the windows buildconfigs and we
need the mozmake tooltool package as well.
Assignee: bugspam.Callek → ewong
Status: NEW → ASSIGNED
Blocks: 1053084
I'm falling further behind on time than I'd like, but I don't want to delay this anymore, lets land these pieces, perform the win host changes.

If we need a moco tooltool package copied to tmp-sm folder (public) let me know before you (ewong) sleep and I'll copy it over during my daytime. And I'll leave this for you to test/verify over the weekend.

Again, please do *land* these patches, if followups are needed attach as *new* [extra] patches on this bug.
Comment on attachment 8443855 [details] [diff] [review]
tools part patch (v1)

(for post-push review)
Pushed to tools:
http://hg.mozilla.org/users/Callek_gmail.com/tools/rev/bd2eb1e6e2c4
Comment on attachment 8443861 [details] [diff] [review]
Buildbot-configs patch (v1)

For post-push review:

Pushed to buildbot-configs:
https://hg.mozilla.org/build/buildbot-configs/rev/1d2fd54c4ba5
Attachment #8488497 - Flags: review?(bugspam.Callek)
Attachment #8488497 - Attachment is obsolete: true
Attachment #8488497 - Flags: review?(bugspam.Callek)
Attachment #8488514 - Flags: review?(bugspam.Callek)
Attachment #8488514 - Attachment is obsolete: true
Attachment #8488514 - Flags: review?(bugspam.Callek)
Attachment #8488523 - Flags: review?(bugspam.Callek)
Depends on: 1066896
Comment on attachment 8443855 [details] [diff] [review]
tools part patch (v1)

Review of attachment 8443855 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with the following applied:

http://hg.mozilla.org/build/tools/rev/76ae29d0a6c9
http://hg.mozilla.org/build/tools/rev/ccf936487928
http://hg.mozilla.org/build/tools/rev/bb2e379769db

::: lib/python/build/l10n.py
@@ -37,1 @@
>      run_cmd(["python", path.join("compare-locales", "scripts",

l10n.py here isn't used by seamonkey yet, afaict. That said the changes are safe.
Attachment #8443855 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 8443861 [details] [diff] [review]
Buildbot-configs patch (v1)

Review of attachment 8443861 [details] [diff] [review]:
-----------------------------------------------------------------

per: http://mxr.mozilla.org/build/search?string=tooltool_script&find=mozilla%2Fconfig.py&findi=&filter=^[^\0]*%24&hitlimit=&tree=build

It certainly looks like the following changes need to be made:

* Remove from global vars, and set in each platform.
* use /builds/tooltool.py rather than /tools/*
* do a mock_copyin entry on linux for the /builds entry.

Also given:

http://mxr.mozilla.org/build/search?string=tooltool_script&find=process%2Frelease.py&findi=&filter=^[^\0]*%24&hitlimit=&tree=build

I expect the http://hg.mozilla.org/build/buildbot-configs/file/seamonkey-production/seamonkey/release_master.py file will need some love for the related factories.
Attachment #8443861 - Flags: review?(bugspam.Callek) → review-
Comment on attachment 8488523 [details] [diff] [review]
buildbotcustom code to support tooltool in Win32 (v2)

Review of attachment 8488523 [details] [diff] [review]:
-----------------------------------------------------------------

this by itself would likely fail buildbot out, since its missing any/all factory.py changes.

Ala: http://mxr.mozilla.org/build/search?string=tooltool_script&find=factory.py&findi=&filter=^[^\0]*%24&hitlimit=&tree=build
Attachment #8488523 - Flags: review?(bugspam.Callek) → review-
Attachment #8488523 - Attachment is obsolete: true
Attachment #8490591 - Flags: review?(bugspam.Callek)
Attachment #8443861 - Attachment is obsolete: true
Attachment #8490592 - Flags: review?(bugspam.Callek)
Attached patch config patch for tooltool (v3) (obsolete) — Splinter Review
Attachment #8490592 - Attachment is obsolete: true
Attachment #8490592 - Flags: review?(bugspam.Callek)
Attachment #8491993 - Flags: review?(bugspam.Callek)
Blocks: 1072713
Duplicate of this bug: 1072714
OS: Windows Vista → All
Attachment #8491993 - Attachment is obsolete: true
Attachment #8491993 - Flags: review?(bugspam.Callek)
Attachment #8494907 - Flags: review?(bugspam.Callek)
Summary: Setup tooltool on SeaMonkey Win32 builders. → Setup tooltool on SeaMonkey Win32 builders and update the other platform's tooltool setup
Comment on attachment 8490591 [details] [diff] [review]
buildbotcustom code to support tooltool in Win32 (v3)

Moved to bug 1072713
Attachment #8490591 - Flags: review?(bugspam.Callek)
Comment on attachment 8494907 [details] [diff] [review]
config patch for tooltool (v4)

Moved to bug 1072713
Attachment #8494907 - Flags: review?(bugspam.Callek)
Fixed in bug 1072713
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.