Closed Bug 1023682 Opened 8 years ago Closed 8 years ago

[Settings] The clear bookmarks data button in the app permissions panel is missing

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: arthurcc, Assigned: eragonj)

References

Details

(Keywords: regression, Whiteboard: [p=1])

Attachments

(1 file, 1 obsolete file)

STR:
1. Launch settings app -> App permissions

Expected result:
  There should be a clear bookmarks data button.

Actual result:
  Clear bookmarks data button is missing.

This was regressed by bug 998847 when we refactored the panel. The button is hidden by default and should be displayed at the time when the app list is ready.
Correction: this was regressed by bug 973454, not 998847.
Stole it.
Assignee: nobody → ejchen
blocking-b2g: 2.0? → 2.0+
QA Wanted to confirm this doesn't happen on 1.4.
Keywords: qawanted, regression
Attached file patch on master
Attachment #8438135 - Attachment is obsolete: true
Comment on attachment 8439075 [details] [review]
patch on master

Hi Arthur, 

can you help me review this patch ? thanks  :]
Attachment #8439075 - Flags: review?(arthur.chen)
This issue DOES occur on the Buri, and Flame 2.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140609223003
Gaia: f42ebc93554979501d3ac52bcf9e69cb4b310a4f
Gecko: 9dc0ffca10f4
Version: 33.0a1 2.0 MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 


Flame 2.0

Environmental Variables:
Device: Flame 2.0
Build ID: 20140612000201
Gaia: 2bb66630315299ca947e40fcec23c9f7ea012111
Gecko: 670d69879f0e
Version: 32.0a2 (2.0) 
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 


When accessing Settings> App Permissions, the 'Clear Bookmarks Data' button is unavailable



This issue does not occur on Buri, or Flame 1.4

Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140612063006
Gaia: 80bf1039c6ce8bcde57ce06ecb09e40c18c538c6
Gecko: 39b6237907d9
Version: 30.0 (1.4) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Flame 1.4

Environmental Variables:
Device: Flame 1.4
Build ID: 20140612000202
Gaia: 7fc73d4cb1bece31f50e8ccf6fb98af3984a9ebf
Gecko: bcd308fbbf38
Version: 30.0 (1.4) 
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


When accessing Settings> App Permissions, the 'Clear Bookmarks Data' button appears at the bottom, and is functional
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Holding off on regression-window keyword as it might waste time as there is already a patch in for review : comment 7
Flags: needinfo?(jmitchell)
Just followed offline discussion with Arthur and applied patch of bug 1012659 here !
Comment on attachment 8439075 [details] [review]
patch on master

r=me with the nit addressed, thanks!
Attachment #8439075 - Flags: review?(arthur.chen) → review+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+][lead-review+]
Target Milestone: --- → 2.0 S4 (20june)
Thanks all, I just merged patches into 

Gaia/master: 5709345df31c5fab5cc5c051d591d4e76ca4f706
Gaia/v2.0: dad9971c03910610defd92d4c1be9b6ca18e1bfa

:P
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1012659
You need to log in before you can comment on or make changes to this bug.