Closed Bug 1023703 Opened 5 years ago Closed 5 years ago

Unable to compile js shells on Windows

Categories

(Firefox Build System :: General, defect, blocker)

x86
Windows 7
defect
Not set
blocker

Tracking

(firefox31 unaffected, firefox32 fixed, firefox33 fixed)

RESOLVED FIXED
mozilla33
Tracking Status
firefox31 --- unaffected
firefox32 --- fixed
firefox33 --- fixed

People

(Reporter: gkw, Assigned: glandium)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [fuzzblocker][npotb])

Attachments

(3 files, 2 obsolete files)

I'm unable to compile js shells on Windows recently.

Steps:
1. In js/src, run autoconf-2.13
2. Create and cd into objdir
3. Run: MAKE=mozmake AR=ar sh ../configure --disable-optimize --enable-debug --enable-profiling --enable-gczeal --enable-debug-symbols --disable-tests --enable-more-deterministic --enable-exact-rooting --disable-threadsafe
4. Run: mozmake -j1

(bug 972089, which is supposed to prevent this breakage by showing SpiderMonkey builds on TBPL, is blocked by bug 975011)

autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   https://hg.mozilla.org/mozilla-central/rev/d959285c827e
user:        Mike Hommey
date:        Fri May 30 09:37:24 2014 +0900
summary:     Bug 1014976 - Slightly clean up ICU setup for windows debug builds. r=mshal

Mike, is bug 1014976 a likely regressor?
Flags: needinfo?(mh+mozilla)
I won't answer any question without my lawyer^W^Wlogs.
Flags: needinfo?(mh+mozilla)
Attached file buildLog.txt
(In reply to Mike Hommey [:glandium] from comment #1)
> I won't answer any question without my lawyer^W^Wlogs.

Lawyer logs? I'm not sure what you really mean, or whatever you intended to say.

Anyway I've attached the build log.
Flags: needinfo?(mh+mozilla)
^W means backspace.
What is MOZ_ICU_DBG_SUFFIX in objdir/config/autoconf.mk ?
Flags: needinfo?(mh+mozilla)
(In reply to Mike Hommey [:glandium] from comment #4)
> What is MOZ_ICU_DBG_SUFFIX in objdir/config/autoconf.mk ?

It's not present in config/autoconf.mk.
How long ago did you run autoconf?
I ran autoconf-2.13 in js/src just before creating the objdir, then I ran the configure command in the objdir, followed by mozmake. (which then failed to compile)
What is MOZ_DEBUG and MOZ_NO_DEBUG_RTL in objdir/config/autoconf.mk?
MOZ_DEBUG = 1

MOZ_NO_DEBUG_RTL is not found.
I think this fixes it. Please test.
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Comment on attachment 8438247 [details] [diff] [review]
Fix static-icu windows builds after bug 1014976

Executing: lib -NOLOGO -OUT:js_static.lib jitprofiling.obj RegExp.obj Parser.obj jsarray.obj jsatom.obj jsmath.obj jsutil.obj ExecutableAllocatorWin.obj MacroAssemblerX86Common.obj pm_stub.obj Unified_cpp_js_src0.obj Unified_cpp_js_src1.obj Unified_cpp_js_src2.obj Unified_cpp_js_src3.obj Unified_cpp_js_src4.obj Unified_cpp_js_src5.obj Unified_cpp_js_src6.obj Unified_cpp_js_src7.obj Unified_cpp_js_src8.obj Unified_cpp_js_src9.obj Unified_cpp_js_src10.obj Unified_cpp_js_src11.obj ..\..\mfbt\Compression.obj ..\..\mfbt\Decimal.obj ..\..\mfbt\Unified_cpp_mfbt0.obj ../../intl/icu/target/lib/icuind.lib ../../intl/icu/target/lib/icuucd.lib ../../intl/icu/target/lib/icudtd.lib
LINK : fatal error LNK1181: cannot open input file '../../intl/icu/target/lib/icuind.lib'

c:/Users/fuzz1win/trees/mozilla-central/config/rules.mk:838: recipe for target 'js_static.lib' failed
mozmake[3]: *** [js_static.lib] Error 1181
c:/Users/fuzz1win/trees/mozilla-central/config/recurse.mk:95: recipe for target 'js/src/libs' failed
mozmake[2]: *** [js/src/libs] Error 2
c:/Users/fuzz1win/trees/mozilla-central/config/recurse.mk:39: recipe for target 'libs' failed
mozmake[1]: *** [libs] Error 2
c:/Users/fuzz1win/trees/mozilla-central/config/rules.mk:592: recipe for target 'default' failed
mozmake: *** [default] Error 2
Attachment #8438247 - Flags: feedback-
Attached file build log for comment 10 (obsolete) —
That log is weird, as it's not running ICU_LIB_RENAME when your previous did and the patch doesn't change that.
ah, it's a make -s log... please don't build with -s.
Attached file Build log take 2
Attachment #8438276 - Attachment is obsolete: true
Flags: needinfo?(mh+mozilla)
Stupid question: did you run autoconf after applying the patch?
Flags: needinfo?(mh+mozilla)
Ah, found a missing bit. Try this one.
Attachment #8438247 - Attachment is obsolete: true
Comment on attachment 8438730 [details] [diff] [review]
Fix static-icu windows builds after bug 1014976

This seems to work fine!
Attachment #8438730 - Flags: feedback+
Attachment #8438730 - Flags: review?(mshal)
Component: JavaScript Engine → Build Config
Attachment #8438730 - Flags: review?(mshal) → review+
Helped to land this since this fixes build breakage. Thanks for the fix!

https://hg.mozilla.org/integration/mozilla-inbound/rev/edf5e2dc9198

Also, this needs backporting to aurora branch as well, since bug 1014976 landed on 32.
Target Milestone: --- → mozilla33
Whiteboard: [fuzzblocker] → [fuzzblocker][npotb][checkin-needed-aurora]
https://hg.mozilla.org/mozilla-central/rev/edf5e2dc9198
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/8784445f4d4f
Whiteboard: [fuzzblocker][npotb][checkin-needed-aurora] → [fuzzblocker][npotb]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.