Closed Bug 1023738 Opened 8 years ago Closed 8 years ago

[Wifi] User can't import certificate when entering "Import certificate" in "Manage certificates" page in first time

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: gchang, Assigned: iliu)

Details

Attachments

(1 file)

### Steps:
1. Generate a certificate and put it on sd card
2. Navigate to Settings > Wi-Fi page
3. Select "Manage certificates"
4. Tap "Import certificate"
5. There is no certificate listed here
6. Click "<" to go back to previous page and click "Import certificate" again
7. The certificate is listed.

### Expected:
The certificate should be listed in first time (in step 5) when "Settings" app is lanuched.

### Actual:
There is no certificate listed.

Additional information:
Once going back to previous page and entering to "Import certificate" page, the certificate will be listed always. But, if "Settings" app is closed and launched again, the certficate won't be listed in first time.

### Reproduce rate
always

### Version:
Device    flame
Gaia      8d865839d932bfbd5e157f376f74d8cb12bfdd51
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/1d4046a8cb6c
BuildID   20140610000223
Version   32.0a2
Summary: [Wifi] User can't import certificate when entering "Import certificate" in "Manage certificates" page first → [Wifi] User can't import certificate when entering "Import certificate" in "Manage certificates" page in first time
blocking-b2g: --- → 2.0?
I'm not able to reproduce the issue.

==== Build version ==== :

Gaia      2402076e6299ab36f492eab17795478c9d2a7ad7
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/c41d7012974e
BuildID   20140617160202
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014

Hi Gerry, what format of certificated file do you use? I use *.pem for reproducing it. It's working for me.
Flags: needinfo?(gchang)
After I rebooted my device again, I can reproduce it now. Clear ni flag.
Flags: needinfo?(gchang)
Looks like the custom event 'scan-certificate-file' is fired before 'wifi-selectCertificateFile' dialog listen it.

Howie, shell we set blocking for the issue on Gaia/v2.0? Thanks.
Flags: needinfo?(hochang)
blocking-b2g: 2.0? → 2.0+
Hi Ian, this is a blocker, assign to you first, thanks.
Assignee: nobody → iliu
Flags: needinfo?(hochang)
Status: NEW → ASSIGNED
Attached file pull request 20720
Ej, could you please help to review my pull request? Thanks:-)
Attachment #8442571 - Flags: review?(ejchen)
Comment on attachment 8442571 [details] [review]
pull request 20720

Thanks Ian, it looks good to me.

And just want to remind you that I am currently working on refactoring Wifi Panel in Settings app. After refactoring, because we will use the new way to display panels so there is no this problem in my local branch.

Thanks :]
Attachment #8442571 - Flags: review?(ejchen) → review+
Target Milestone: --- → 2.0 S4 (20june)
Thanks for EJ's reviewing effort and reminds. Since the pr is landed, we can close the issue now.

Gaia/master:  faad5c374ec4b7fbfd88e3a91c1e030ab612d24a
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Gaia/v2.0:  b0d6de812c8ac5fc263cc47fa3bfb2cb9d59131d
Verified @
Gaia      43226cf5c3ad19728a88b3786595670b6d60e5c6
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/d0275ba5f438
BuildID   20140701160202
Version   32.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.