HashCompleterRequest.notifyFailure doesn't work.

RESOLVED FIXED in mozilla33

Status

()

Toolkit
Safe Browsing
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: pzhang, Assigned: pzhang)

Tracking

unspecified
mozilla33
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 8438297 [details] [diff] [review]
0001-Fix-bug-HashCompleterRequest.notifyFailure-doesn-t-w.patch
Attachment #8438297 - Flags: review?(dcamp)
(Assignee)

Comment 1

4 years ago
This might be duplicate of bug 832056.
(Assignee)

Updated

4 years ago
Attachment #8438297 - Flags: review?(dcamp) → review?(mmc)
Comment on attachment 8438297 [details] [diff] [review]
0001-Fix-bug-HashCompleterRequest.notifyFailure-doesn-t-w.patch

Pin, thank you for fixing this bug that has been present since 2011. Were you able to verify that this patch solved the hanging gethash problem?
Attachment #8438297 - Flags: review?(mmc) → review+
(Assignee)

Comment 3

4 years ago
(In reply to [:mmc] Monica Chew (please use needinfo) from comment #2)
> Comment on attachment 8438297 [details] [diff] [review]
> 0001-Fix-bug-HashCompleterRequest.notifyFailure-doesn-t-w.patch
> 
> Pin, thank you for fixing this bug that has been present since 2011. Were
> you able to verify that this patch solved the hanging gethash problem?

No, in that case, onStopRequest never got invoked.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/26c547fba1c4
Assignee: nobody → pzhang
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/26c547fba1c4
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33

Updated

4 years ago
Depends on: 1063316
You need to log in before you can comment on or make changes to this bug.