[Flame][v1.4][Contacts]The crash happened when export more than 750 contacts to SIM card.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Contacts
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: greatwall2686, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: torch)

(Reporter)

Description

4 years ago
* Description:
  The crash happened when export more than 750 contacts to SIM card.
  Here are the detailed information:
   - Title:
     ~ B2G 30.0 Crash Report [@ wpa_ctrl_recv ]

   - Crash Report:
     ~ https://crash-stats.mozilla.com/report/index/da146791-c569-402a-89df-f72b92140611

* Pre-condition:
  1. More than 250 contacts are created in SIM card
  2. More than 750 contacts are created in local memory

* Reproduction steps:
  1. Launch the Contacts app and tap the Settings icon
  2. Select Export Contacts then SIM card
  3. Select all contacts then Export
  4. Check the result

* Expected result:
  Export start, while export job is done, user will be informed the number of contacts been exported and the number of contacts not been exported.

* Actual result:
  After a moment, a system crash happened

* Reproduction build:(Buri - Firefox OS V1.4 inside)
 - Gaia      17b102ee8d9a724b62285547cc5f1c5d30bfb01c
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/95be84248033
 - BuildID   20140520000201
 - Version   30.0
Jose, do we have confirmation when the sim card is full?
Flags: needinfo?(jmcf)

Comment 2

4 years ago
Yes, when the SIM card is full we show a message in Gaia, bug iccManager must raise it through an error
Flags: needinfo?(jmcf)
Crash Signature: [@ wpa_ctrl_recv ]
Looking at the crash report that was mentioned an looking at the steps; the crash report shouldn't be related.  The crash report is in regards to wifi.  Wifi is not mentioned in the STRs.

Please check the adb shell dmesg and/or the logcat to see what occurred.
Crash Signature: [@ wpa_ctrl_recv ]
Flags: needinfo?(greatwall2686)
Hi Naoki,
     This issue is reported by contracting team, and the trial run has been finished. The bugs filed by them will be handled by me now.  
     
     I follow the steps to reproduce it for 30 times, but it could not be reproduced in the same build and newer build (BuildID: 20140618000203).
Blocks: 1015217
Flags: needinfo?(greatwall2686)
Whiteboard: torch
Change status to works for me due to I COULD NOT reproduce this issue (see comment 4)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.