Don't show tracebacks in validation results

RESOLVED FIXED in 2014-06-17

Status

Marketplace
Validation
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kumar, Assigned: mstriemer)

Tracking

2014-06-17
x86
Mac OS X
Points:
---

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Created attachment 8438544 [details]
Screen Shot 2014-06-11 at 12.08.47 PM.png

If the validator raises an exception, the Marketplace shows the full traceback in app submission and the validation tester. Let's not show the traceback because there's a chance that sensitive info might leak.

STR
- cause the validator to raise an exception
- upload an app or use the tester

It should fail with 'unexpected internal error' or something like that.

See bug 1023490 for an example
(Assignee)

Comment 1

3 years ago
Looks like we're exposing tracebacks everywhere except for development. I'll switch that around.

$ git grep EXPOSE_VALIDATOR_TRACEBACKS
lib/settings_base.py:EXPOSE_VALIDATOR_TRACEBACKS = False
mkt/developers/views.py:    if not settings.EXPOSE_VALIDATOR_TRACEBACKS:
sites/altdev/settings_base.py:EXPOSE_VALIDATOR_TRACEBACKS = True
sites/dev/settings_base.py:EXPOSE_VALIDATOR_TRACEBACKS = True
sites/identitystage/settings_base.py:EXPOSE_VALIDATOR_TRACEBACKS = True
sites/landfill/settings_base.py:EXPOSE_VALIDATOR_TRACEBACKS = True
sites/paymentsalt/settings_base.py:EXPOSE_VALIDATOR_TRACEBACKS = True
sites/prod/settings_base.py:EXPOSE_VALIDATOR_TRACEBACKS = True
sites/stage/settings_base.py:EXPOSE_VALIDATOR_TRACEBACKS = True
Assignee: nobody → mstriemer
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
https://github.com/mozilla/zamboni/pull/2189
(Assignee)

Comment 3

3 years ago
https://github.com/mozilla/zamboni/commit/3579a97f906dd22e908daf6c375caf05f89338af
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-06-17

Comment 4

3 years ago
Issue is still reproducing in https://marketplace.allizom.org/developers/validator on FF33 (Win 7). On -dev, the app passes validation with no error
Please see screencast http://screencast.com/t/Rz8LVD5NNt17
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

3 years ago
The stage deploy failed last week, this is on stage now. Unfortunately the addon we used for the traceback no longer errors though.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Comment 6

3 years ago
Can you please provide us an app that raises an exception in order to verify this issue? Thank you!
Flags: needinfo?(mstriemer)
(Assignee)

Comment 7

3 years ago
I unfortunately don't know of an app that will raise an error. Since this was just a config change and it worked locally I'm thinking we can leave it and open a new bug if it somehow shows up again later.
Flags: needinfo?(mstriemer)
Whiteboard: [qa-]
See Also: → bug 1056224
You need to log in before you can comment on or make changes to this bug.