Closed Bug 1024126 Opened 6 years ago Closed 6 years ago

Add a danger zone to SharedFrameMetricsHelper::AboutToCheckerboard()

Categories

(Core :: Graphics: Layers, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
firefox31 --- wontfix
firefox32 --- fixed
firefox33 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: kats, Assigned: kats)

References

Details

Attachments

(1 file)

As mentioned at https://bugzilla.mozilla.org/show_bug.cgi?id=1006579#c5 and https://bugzilla.mozilla.org/show_bug.cgi?id=1021248#c9, the AboutToCheckerboard function is really an IsCheckerboarding function at the moment. We should expand the currently-visible rect from the compositor (making sure to still clamp it to page bounds and so on) by a "danger zone" (see the equivalent Fennec code in DisplayPortCalculator.java).

Note that making this change will mean we drop into low-res painting more frequently that we do now, which may or may not be a good thing.
This bug should also replace the Inflate added in https://hg.mozilla.org/integration/mozilla-inbound/rev/a73ed980626f with something like FuzzyContains to deal with rounding error better. I think half an app unit would probably make for a good epsilon for the fuzzy compare.
Attached patch PatchSplinter Review
Needs a bit more testing.
Assignee: nobody → bugmail.mozilla
Comment on attachment 8444705 [details] [diff] [review]
Patch

Review of attachment 8444705 [details] [diff] [review]:
-----------------------------------------------------------------

Nice :) We should try at some point to find good default values for those prefs - but really, we need to decide on that per device spec...
Attachment #8444705 - Flags: review?(chrislord.net) → review+
https://hg.mozilla.org/mozilla-central/rev/c6a7886cde25
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Comment on attachment 8444705 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): enabling progressive painting
User impact if declined: occasionally we could get stuck in a state where part of the content isn't painted, due to rounding errors.
Testing completed (on m-c, etc.): locally, on m-c
Risk to taking this patch (and alternatives if risky): fairly low risk. affects b2g only. might want to bake a few more days before uplifting to ensure this doesn't break anything.
String or IDL/UUID changes made by this patch: none
Attachment #8444705 - Flags: approval-mozilla-aurora?
Comment on attachment 8444705 [details] [diff] [review]
Patch

Baked enough. Approving.
Attachment #8444705 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 1034240
You need to log in before you can comment on or make changes to this bug.