nsIWebShell's GetURL using const PRUnichar**

RESOLVED FIXED

Status

()

RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: aaronlev, Assigned: adamlock)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Should not be const

Needs to be fixed so we can use getter_Copies with an XPIDLString
(Reporter)

Updated

17 years ago
Blocks: 102411
(Assignee)

Comment 1

17 years ago
Created attachment 52499 [details] [diff] [review]
Patch removes the const keyword, reviews please
(Assignee)

Updated

17 years ago
Keywords: review

Comment 2

17 years ago
Looks good, except that in mozilla/webshell/tests/viewer/nsBrowserWindow.cpp
near where you made the change there you're leaking the PRUnichar* you're
getting. Not necessarily part of this patch, but you may want to fix that while
you're there (using nsXPIDLString and getter_Copies).

r=jag

Updated

17 years ago
Attachment #52499 - Flags: review+
(Assignee)

Comment 3

17 years ago
Created attachment 52507 [details] [diff] [review]
Second patch with getter_Copies
(Assignee)

Comment 4

17 years ago
*** Bug 102410 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
Comment on attachment 52507 [details] [diff] [review]
Second patch with getter_Copies

r=jag

I like this :-)
Attachment #52507 - Flags: review+

Comment 6

17 years ago
(Of course, I could point out that one could save that string copy by making
ViewSource take const nsAString& instead of nsString, but that is really a
different bug altogether, so I won't ;-) ).

Comment 7

17 years ago
Comment on attachment 52507 [details] [diff] [review]
Second patch with getter_Copies

sr=rpotts@netscape.com
Attachment #52507 - Flags: superreview+
(Assignee)

Comment 8

17 years ago
Fix is checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.