If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Win64 REFTEST TEST-UNEXPECTED-PASS | file:///C:/slave/test/build/tests/reftest/tests/layout/style/crashtests/413274-1.xhtml | assertion count 0 is less than expected 2 assertions

RESOLVED DUPLICATE of bug 576435

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 576435
3 years ago
3 years ago

People

(Reporter: dmajor, Unassigned)

Tracking

32 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=41407446&tree=Date
(Reporter)

Comment 1

3 years ago
The "expected" asserts that we're not getting on win64 are:

###!!! ASSERTION: How can this ever happen?: '*aUnconstrainedSize <= scriptLevelSize', file s:\central\layout\style\nsRuleNode.cpp, line 2765

###!!! ASSERTION: scriptminsize should never be making things bigger: 'aFont->mScriptUnconstrainedSize <= aFont->mSize', file s:\central\layout\style\nsRuleNode.cpp, line 3728
(Reporter)

Comment 2

3 years ago
*aUnconstrainedSize = 0x18138400 (403932160)
scriptLevelSize = 0xc0000000 (-1073741824)

Some floating-point math may have gone wrong. The asserts on Win32 go away if I remove the X86 perf shortcut in NSToCoordRound.
(Reporter)

Comment 3

3 years ago
What this boils down to is that on 32-bit Windows, NSToCoordRound(nscoord_MAX) is negative, despite the assurances in NS_lroundup30: http://hg.mozilla.org/mozilla-central/annotate/c482c28b35b6/xpcom/ds/nsMathUtils.h#l38
Let's just remove the lround30 code altogether.
(Reporter)

Updated

3 years ago
Blocks: 413787
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 576435
You need to log in before you can comment on or make changes to this bug.