[7715] fail to distinguish between 2G and 3G operator with all operator .

RESOLVED DUPLICATE of bug 997071

Status

Firefox OS
RIL
--
major
RESOLVED DUPLICATE of bug 997071
4 years ago
4 years ago

People

(Reporter: Lina.Guo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

1.19 MB, application/x-zip-compressed
Details
75.15 KB, application/x-zip-compressed
Details
(Reporter)

Description

4 years ago
[1.Hardware Version ]: 7715 FirefoxOS /589#
[2.Project Build    ]: FIREFOXOS_V1.4_W14.21.5_SP7715
(FIREFOXOS_V1.4_SP7715_Hudson#124)/sp7715ea_gonk4.4.pac
[3.Network          ]: GSM
[4.Storage Card     ]: 4 GB
[5.SIM Card         ]: SIM1:-Banglalink, SIM2:- GP
Test on :              SIM1:-Banglalink
[6.Testing Location ]: Dynamic 
[7.Testing Steps    ]:
  a) go network search 
  b) 7715 firefox search network(do manual PLMN search) 
  c) 7715 fail to distinguish between 2G and 3G operator with all operator .
    when we do manual PLMN search ,it shows like 
      Airtel
      Airtel
      GP
      Gp
    where it should be like
      Airtel 2G
      Airtel 3G
      GP 2G
      GP 3G
(Reporter)

Comment 1

4 years ago
Created attachment 8438865 [details]
7715_FFX_Banglalink_GP_PLMN.zip

We look at the code in gaia-apps-settings-carrier.js,from the API:mozMobileConnections,we can get the networkInfo,but it just contain:longname,shortname,mcc,mnc,rilMessageClientId,cell,gsmLocationAreaCode,gsmCellId,type,signalStrength,relSignalStrength,state.Have not the network type like 2G or 3G.
Please confirm whether or not include this field,thanks!
Flags: needinfo?(ttsai)

Updated

4 years ago
Component: Gaia::Settings → RIL
(Reporter)

Comment 2

4 years ago
I'm sorry,could you say a little more detail. How can I get the 2G or 3G by ril in the upper?
I also can't find. thanks!
(In reply to Lina.Guo from comment #1)
> Created attachment 8438865 [details]
> 7715_FFX_Banglalink_GP_PLMN.zip
> 
> We look at the code in gaia-apps-settings-carrier.js,from the
> API:mozMobileConnections,we can get the networkInfo,but it just
> contain:longname,shortname,mcc,mnc,rilMessageClientId,cell,
> gsmLocationAreaCode,gsmCellId,type,signalStrength,relSignalStrength,state.
> Have not the network type like 2G or 3G.
> Please confirm whether or not include this field,thanks!

There are so many files in .zip. Please kindly point out which one is the right log file, thanks.
(Reporter)

Comment 4

4 years ago
Created attachment 8438966 [details]
0-main-08-18-19.log.zip

This is an always recurrence bug,this log may have not much help to solve the problem.
I hope to know if there is a API,from it I can get the network type for 2G or 3G,thanks!
(In reply to Lina.Guo from comment #4)
> Created attachment 8438966 [details]
> 0-main-08-18-19.log.zip
> 
> This is an always recurrence bug,this log may have not much help to solve
> the problem.
> I hope to know if there is a API,from it I can get the network type for 2G
> or 3G,thanks!

Yes, here it is:

http://dxr.mozilla.org/mozilla-central/source/dom/webidl/MozMobileConnectionInfo.webidl?from=MozMobileConnectionInfo.webidl#49

And possible values:
http://dxr.mozilla.org/mozilla-central/source/dom/webidl/MozMobileConnectionInfo.webidl?from=MozMobileConnectionInfo.webidl#6

According to the values, you should be able to know if it's 2G or 3G.
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #5)
> (In reply to Lina.Guo from comment #4)
> > Created attachment 8438966 [details]
> > 0-main-08-18-19.log.zip
> > 
> > This is an always recurrence bug,this log may have not much help to solve
> > the problem.
> > I hope to know if there is a API,from it I can get the network type for 2G
> > or 3G,thanks!
> 
> Yes, here it is:
> 
> http://dxr.mozilla.org/mozilla-central/source/dom/webidl/
> MozMobileConnectionInfo.webidl?from=MozMobileConnectionInfo.webidl#49
> 
> And possible values:
> http://dxr.mozilla.org/mozilla-central/source/dom/webidl/
> MozMobileConnectionInfo.webidl?from=MozMobileConnectionInfo.webidl#6
> 
> According to the values, you should be able to know if it's 2G or 3G.

Oh, I seem misunderstand your questions.
The issue is talking about when user manual scan network operators in the area, user has no way to know the operator type.

Hmmm, when gaia queries mobielConnection.getNetworks() the return result is the array of mobileNetworkInfo. And now, mozMobileNetworkInfo doesn't provide 'type' attribute [1].

[1] http://dxr.mozilla.org/mozilla-central/source/dom/webidl/MozMobileNetworkInfo.webidl#10
This is a dup of bug 997071. I guess this bug had more info here.
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #6)
> 
> Oh, I seem misunderstand your questions.
> The issue is talking about when user manual scan network operators in the
> area, user has no way to know the operator type.
> 
> Hmmm, when gaia queries mobielConnection.getNetworks() the return result is
> the array of mobileNetworkInfo. And now, mozMobileNetworkInfo doesn't
> provide 'type' attribute [1].
> 
> [1]
> http://dxr.mozilla.org/mozilla-central/source/dom/webidl/
> MozMobileNetworkInfo.webidl#10

The return value is determined according to ril.h [1].
There's no information about the network type. Gecko provides what we could get from rild/modem.

[1] http://code.metager.de/source/xref/android/4.4/hardware/ril/include/telephony/ril.h#2192

Updated

4 years ago
Status: NEW → RESOLVED
blocking-b2g: 1.4? → ---
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 997071

Comment 10

4 years ago
Hsin-Yi is working on, so I clear Ni.
Flags: needinfo?(ttsai)
(In reply to thomas tsai from comment #10)
> Hsin-Yi is working on, so I clear Ni.

Please see comment 8 and bug 997071 comment 3. I believe this is a customization issue. We won't and have no way to resolve this in reference phone.
You need to log in before you can comment on or make changes to this bug.