Closed Bug 1024333 Opened 5 years ago Closed 5 years ago

[v1.4][UX]Cannot turn off recent app page by tapping screen when "No recent app" is display.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: greatwall2686, Assigned: yifan)

References

Details

(Whiteboard: torch, [good first bug])

Attachments

(2 files)

Attached image 2014-06-12-15-07-19.png
* Description: 
Cannot turn off recent app page by tapping screen when "No recent apps" is display.
* Reproduction steps:
  1. Long press HW power key->"Restart".
  2. Long press HW home key
  3. Tap "Recent app" page.
* Expected result:
User can turn off recent app page by tapping screen.
* Actual result: 
Cannot turn off recent app page by tapping screen. 

* Reproduction build:(Buri - Firefox OS V1.4 inside)
 - Gaia      17b102ee8d9a724b62285547cc5f1c5d30bfb01c
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/95be84248033
 - BuildID   20140520000201
 - Version   30.0

* Reproduction Frequency
  - 100%
This issue is also reproducible on Buri 1.3. Hence, this seems to be a question for UX.
Component: Gaia::Homescreen → Gaia::System::Window Mgmt
Flags: needinfo?(firefoxos-ux-bugzilla)
Summary: [Flame][v1.4][Gaia::Homescreen][UX]Cannot turn off recent app page by tapping screen when "No recent app" is display. → [v1.4][UX]Cannot turn off recent app page by tapping screen when "No recent app" is display.
Confirmed bug: user should be able to complete the expected behavior, which is to turn off the recent app page. Right now, it looks like the only way out of this is to... exit through Home button?
Flags: needinfo?(firefoxos-ux-bugzilla)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: torch → torch, [good first bug]
Assignee: nobody → yliao
Status: NEW → ASSIGNED
The empty cards view can be closed when user taps the screen.
Please help to review the code changes, thank you.
Attachment #8451432 - Flags: review?(alive)
Comment on attachment 8451432 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/21427

1. Please describe what is fixed in your commit message but not the bug summary
2. Please start to learn writing unit testing:
https://developer.mozilla.org/en-US/Firefox_OS/Platform/Automated_testing/Gaia_unit_tests
Attachment #8451432 - Flags: review?(alive)
Comment on attachment 8451432 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/21427

The update of the pull request is as follows:
* Check if the cardsView is empty and should be closed or not in the onStartEvent event handler.
* Add test for closing empty cardsview by touchstart.
Attachment #8451432 - Flags: review?(alive)
Merged in master branch.

https://github.com/mozilla-b2g/gaia/commit/91a93acdf8609f2d2f8871bacd7bd31f89bbb881

https://travis-ci.org/mozilla-b2g/gaia/builds/29854014
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1032701
You need to log in before you can comment on or make changes to this bug.