[tarako][dolphin][mali gpu] debug method

RESOLVED INVALID

Status

Firefox OS
Performance
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: ying.xu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Reporter)

Comment 1

4 years ago
GPU usage  xxx/256
sys/kernel/debug/mali0

root@scx15_sp7715ga:/sys/kernel/debug/mali0 # ls utilization*
utilization_gp      vertixes
utilization_gp_pp
utilization_pp      pixel

root@scx15_sp7715ga:/sys/kernel/debug/mali0 # cat utilization*                 
42
230
229
(In reply to ying.xu from comment #2)
> Mali Graphics Debugger
> http://malideveloper.arm.com/develop-for-mali/tools/analysis-debug/mali-
> graphics-debugger/

Hi Ying,
Could we use this mali graphic tool for tarako and dolphin device now?
Flags: needinfo?(ying.xu)
Hi James,
Ying demos the mali gpu tool at other platform. I think it's useful for tarako or dolphin gpu problem.
Do we have progress to use mali tool at b2g?
Flags: needinfo?(james.zhang)
Flags: needinfo?(james.zhang)
Ying, I have added Andrew here.
Can you clarify what the problem being reported is, and what condition needs to be met for resolution?
Joe, any comment on this one?
Flags: needinfo?(jcheng)
(Reporter)

Comment 8

4 years ago
this is not a bug, just write the ways to debug graphics problems.

Hi, hshis.
I don't have time to try the tools in Comment 2.
If you would like, you can try it by yourself.
If meeting problems , you can ask andrew.wu for help.
redirect ni? to wchang/ryang
Flags: needinfo?(wchang)
Flags: needinfo?(ryang)
Flags: needinfo?(jcheng)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(wchang)
Resolution: --- → INVALID
Flags: needinfo?(ryang)
(Reporter)

Updated

4 years ago
Flags: needinfo?(ying.xu)
You need to log in before you can comment on or make changes to this bug.