execute jshint for build directory

RESOLVED FIXED

Status

Firefox OS
Gaia::Build
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: yurenju, Assigned: rickychien)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
gduan
: review+
Details | Review | Splinter Review
we should execute jshint for build directory since we put a lot of js files there.
Depends on: 1031992
Depends on: 1031994
Depends on: 1031997
Depends on: 1031998
Depends on: 1032000
Depends on: 1032001
Depends on: 1032002
Depends on: 1032004
Depends on: 1032005
Depends on: 1032006
Depends on: 1032008
Depends on: 1032020
Depends on: 1032022
Depends on: 1032023
Depends on: 1032024
Depends on: 1032026
Depends on: 1032028
Depends on: 1032030
Depends on: 1032032
Depends on: 1032033
Depends on: 1032036
Depends on: 1032038
Depends on: 1032040
Depends on: 1032041
Depends on: 1032043
Depends on: 1032044
Depends on: 1032045
Depends on: 1032048
Depends on: 1032050
Depends on: 1032051
solving all of jshint related bugs should do those things:

1. remove certain js file in .jshintignore (for example build/webapp-optimize.js)
2. execute |jshint build/JS_FILE|
3. fix all jshint error/warning
4. send a pull request and check the result on tbpl (tbpl bot will automatically comment on your pull request)

please needinfo? me if you have any question.
(Assignee)

Comment 2

3 years ago
There are so many joshing errors in current build/test/ and not only build/testintegration/build.test.js.
So I prefer to fix all of them once in this bug and close bug 1032030 since it seems to be no progress recently.
Assignee: nobody → ricky060709
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1032030
(Assignee)

Comment 4

3 years ago
Created attachment 8541424 [details] [review]
Gaia PR
Attachment #8541424 - Flags: review?(gduan)
(Assignee)

Updated

3 years ago
Attachment #8541424 - Attachment description: Gaia PR WIP → Gaia PR
Comment on attachment 8541424 [details] [review]
Gaia PR

good job! r=gduan
Attachment #8541424 - Flags: review?(gduan) → review+
(Assignee)

Comment 6

3 years ago
Thanks. Let's merge it.

https://github.com/mozilla-b2g/gaia/commit/05211357a49df83310bd3901d6bbb25ac5e2c41e
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.