Cannot back to homescreen from camera mode

RESOLVED DUPLICATE of bug 1030415

Status

RESOLVED DUPLICATE of bug 1030415
5 years ago
4 years ago

People

(Reporter: atsai, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Reporter)

Description

5 years ago
Environment pre-condition:
A SIM card with SIM code

STR:
1. Reboot device
2. After booting is ready, launch camera app from lockscreen
3. press home button
4. Press power key to lock screen
5. Press power key to wake up the device
6. Unlock screen, and enter correct pin code

Expected Result:
*. After tapping on home button, I can back to homescreen

Acutual Result:
3. still in Camera app, and unable to go to homescreen
6. Still in Camera app, and unable to go to homescreen

=== BUILD INFO ===
DuT       Flame
Gaia      f42ebc93554979501d3ac52bcf9e69cb4b310a4f
Gecko     https://hg.mozilla.org/mozilla-central/rev/9dc0ffca10f4
BuildID   20140610040208
Version   33.0a1
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
This is probably an issue with the window manager.
Component: Gaia::Camera → Gaia::System::Window Mgmt
QA Wanted to check 2.0.
Keywords: qawanted
This issue DOES reproduce on Flame 2.0, Open C 2.0, Open C 2.1:

Flame 2.0

Environmental Variables:
Device: Flame 2.0
Build ID: 20140627000201
Gaia: 8df02268fcd7e80c5fab8c1ec099772e37f8659d
Gecko: 731a5e8831e6
Version: 32.0a2 (2.0)
Firmware Version: v122

Open C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL

Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140627093529
Gaia: b8f36518696f3191a56e4f33447ee9d6ec820da1
Gecko: c90b38c47a1d
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
The device was still in the Cameral app and unable to to go homescreen after STR #3 and #6 from Comment 0.

-------------------------------------------------------------------------------------
This issue does NOT reproduce on Buri 2.1, Buri 2.0, Flame 1.4, Buri 1.4:

Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140610184911
Gaia: 0750f66a0004870773c9a743fa6bdbe124379336
Gecko: 75377bac231e
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140627000201
Gaia: 8df02268fcd7e80c5fab8c1ec099772e37f8659d
Gecko: 731a5e8831e6
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg

Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140627000201
Gaia: 76e669c6fa387f97bcaaaee5d179ee4a9dcca986
Gecko: d956b3a3e921
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg

Flame 1.4

Environmental Variables:
Device: Flame 1.4
Build ID: 20140625000201
Gaia: c9416de14acf9e94ab006619cd2418c768422fcb
Gecko: cddf88f78632
Version: 30.0 (1.4)
Firmware Version: v122

The user was able to go to the Homescreen after pressing the homescreen on the Camera app.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: ychung
Nomming for 2.0, issue is a regression and a significant impact, not being able to return to the homescreen
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
closing this as a dupe of bug 1030415  - This bug obviously came first but the other one has a bit clearer steps, a video attached, and is further along (more traction) than this one.
Status: NEW → RESOLVED
blocking-b2g: 2.0+ → ---
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage+]
Keywords: regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1030415
You need to log in before you can comment on or make changes to this bug.