make test-perf fails with NPM error

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: davehunt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

make test-perf is currently failing with the following trace:

npm ERR! Error: failed to fetch from registry: archiver
npm ERR!     at /usr/share/npm/lib/utils/npm-registry-client/get.js:139:12
npm ERR!     at cb (/usr/share/npm/lib/utils/npm-registry-client/request.js:31:9)
npm ERR!     at Request._callback (/usr/share/npm/lib/utils/npm-registry-client/request.js:136:18)
npm ERR!     at Request.callback (/usr/lib/nodejs/request/main.js:119:22)
npm ERR!     at Request.<anonymous> (/usr/lib/nodejs/request/main.js:212:58)
npm ERR!     at Request.emit (events.js:88:20)
npm ERR!     at ClientRequest.<anonymous> (/usr/lib/nodejs/request/main.js:412:12)
npm ERR!     at ClientRequest.emit (events.js:67:17)
npm ERR!     at HTTPParser.onIncoming (http.js:1261:11)
npm ERR!     at HTTPParser.onHeadersComplete (http.js:102:31)
Created attachment 8439107 [details]
console.log

Full console log from Jenkins.
Comment 0 was from our new Jenkins instance, our old Jenkins instance is giving a different error:

npm ERR! Error: No compatible version found: mime@'^1.2.11'
npm ERR! Valid install targets:
npm ERR! ["1.0.0","1.1.0","1.2.1","1.2.2","1.2.3","1.2.4","1.2.5","1.2.6","1.2.7","1.2.8","1.2.9","1.2.10","1.2.11"]
npm ERR!     at installTargetsError (/usr/lib/node_modules/npm/lib/cache.js:709:10)
npm ERR!     at /usr/lib/node_modules/npm/lib/cache.js:631:10
npm ERR!     at saved (/usr/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:138:7)
npm ERR!     at Object.oncomplete (fs.js:107:15)

I notice the two deployments have different versions of node/npm. Is there a specific version we should be using? I'll see if I can update all nodes to the latest versions.
Attachment #8439107 - Attachment mime type: text/x-log → text/plain
(In reply to Dave Hunt (:davehunt) from comment #2)

> I notice the two deployments have different versions of node/npm. Is there a
> specific version we should be using? I'll see if I can update all nodes to
> the latest versions.

Node 0.6.xx looks like that antique that Ubuntu 12.04 ship with. In my experience it is way too old - I always had to install 0.10.xx.
Flags: needinfo?(dave.hunt)
Also for the error in comment 2, please ping jlal, he did that change.
The first build failing with comment 2 appears to be: Build #3387 (Jun 11, 2014 6:36:17 AM)

Before that, the failure was:

npm ERR! Error: No compatible version found: archiver@'^0.10.0'
npm ERR! Valid install targets:
npm ERR! ["0.1.0","0.1.1","0.2.0","0.2.1","0.2.2","0.3.0","0.4.0","0.4.1","0.4.2","0.4.3","0.4.4","0.4.5","0.4.6","0.4.7","0.4.8","0.4.9","0.4.10","0.5.0-alpha","0.5.0","0.5.1","0.5.2","0.6.0","0.6.1","0.7.0","0.7.1","0.8.0","0.8.1","0.9.0","0.9.1","0.10.0-alpha","0.10.0"]
npm ERR!     at installTargetsError (/usr/lib/node_modules/npm/lib/cache.js:709:10)
npm ERR!     at /usr/lib/node_modules/npm/lib/cache.js:631:10
npm ERR!     at saved (/usr/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:138:7)
npm ERR!     at Object.oncomplete (fs.js:107:15)

This failure appears to have started sometime after: Build #2701 (May 14, 2014 7:05:25 PM). We only keep the last 100 builds, and many of those were affected by the Hamachi build being too large to flash to the device.
Flags: needinfo?(dave.hunt)
It would appear that updating npm and node has resolved these issues on our new Jenkins. I'm going to try to do the same on the old Jenkins to see if it help there too.
Yes, updating appears to have fixed the issue. Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.