General report about v1.4 setbacks from v1.1

RESOLVED INVALID

Status

Firefox OS
General
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: C. sanchiavedraZ, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Hello dear FfOS devs.

I've been trying to contribute as much as I can but there are several things I wanted to let you know about v1.4 but don't have the time to create one by one issues.
So given that I don't have any proper mail to send you this (at least it's not easily findable), I think it's  better to inform you than to not, and I do in a private way because I prefer to help with my modest two cents and not to make any damage, because an ordinary user wouldn't stand easily so many problems even with a recent version.
There are so many drawbacks in v1.4 compared to v1.1 that makes me moving on right to a newer version for several reasons after just one or two months of testing. Try to condense some in here:

- Most of the previous issues I've created are present in v1.4, and there were not any update or upgrade when testing v1.1. Some of them critical for an ordinary user:
    * battery lifetim and warnings when it's getting low/critical
    * systems shutdown itself without warning, 
    * answering/cutting a call is still tricky,
    * favorite contacts are not pre-loaded by default...

Battery:
- Battery consumption is higher (although v1.1 wasn't so good), and battery gets dangerously hot to have your phone in your pocket as it's usual. The system's performance and response also degrades quite dramatically when battery is yellow or red.
    INFO:
    * less than 16h duration with a low/conservative usage and consume profile (Wifi or just 2G outdoors for less consumption, Automatic Brilliance, one Instant messaging app on background, and reading something online, from time to time; no video). 
    * 6-7h with an ordinary user usage profile (IM, mail, internet, calendar, video, streaming)

Vídeo:
- When a video (any kind/format) ends it almost always freezes the system for a minute or more.
- Now fullscreen button appears just some times, most of the times don't.

Everything me search:
- Search never worked since v1.4 installation, just shows installed apps sometimes
- You can't delete an icon/uninstall, it crashes every time (you press long and then it freezes for several seconds/minutes and crashes)

Alarm:
- I created an issue about alarm app getting blank and not working as it should, and now it has same behavior but it doesn't get blank. Anyway buttons are useless and you cannot even close the app, having to reboot the system. Alarm is vital to any ordinary user and it this state it can cause problems to the user because it's still not reliable at all. Using side buttons would be great but not vital.

Files:
- With any file browser app, there are times where files (i.e. you want to delete to free some space) don't appear even if you force refreshing, but you know they are there. So you always are dependent of external hosts to delete them.
- Downloading files is still tricky and unreliable: You download a file and sometimes it is incomplete or doesn't show up in a file browser app; there's no downloading progress info nor warning when it's completed. They don't even appear on Settings > Downloads (it surely happens with audio files).

Connection:
- Wifi button is unresponsive (actually buttons in general), you touch it and nothing happens and there's no feedback about what's happening behind. Then you do it again several times and it does strange things or just seems it got idled; when you go to check Wifi state inside Settings, Wifi seems to react and you see wifi button switching on and off as if connection service was waking up from sleeping. 
- Sometimes system doesn't connect to usual wifi spots and leaves system without wifi connection, even if nothing's wrong with the wifi connection.
- Due to this factors, IM apps and other get stucked in a state where they have no wifi connection but the system doesn't provide an alternative flow of data (2G/3G). And all of this without warning, so sometimes user ends up realizing he's been disconnected for several hours and manually he has to force wifi to react and connect.

My apologies for this monolithic report instead of several issues. Hope you understand that I do with all my good intention and I really thank you for all your efforts and good job, that is a huge lot.
Thanks.

P.S: This can be continued via mail if you prefer. And I prefer anyway to keep it hidden/private for anonymity and private reasons, the goal is helping not fame ;)
this bug does not need to be sec-sensitive
Group: core-security
(Reporter)

Comment 2

4 years ago
(In reply to Curtis Koenig [:curtisk] from comment #1)
> this bug does not need to be sec-sensitive

I specified about keeping it hidden and communication via mail on my P.S. and I explained reasons why, and I see that now is public and that it's been ignored completely. Quite unfair and absolutely disappointing to keep people involved.
(Reporter)

Updated

4 years ago
Group: core-security
(In reply to C. sanchiavedraZ from comment #2)
> (In reply to Curtis Koenig [:curtisk] from comment #1)
> > this bug does not need to be sec-sensitive
> 
> I specified about keeping it hidden and communication via mail on my P.S.
> and I explained reasons why, and I see that now is public and that it's been
> ignored completely. Quite unfair and absolutely disappointing to keep people
> involved.

Mozilla does not hide bugs for anonymity, that is specifically stated in the privacy policy for both Mozilla and bugzilla. We have open bugs and open development so that we can all work together on the project. Security flags are specifically for issues in our products that will cause harm to users. As there is no such harm here there is no reason to keep this bug closed. Closed bugs can only be viewed by a small number of Mozillians and as such we use them as sparingly as possible. As such the security flags on this bug are entirely in appropriate. 

Items of the nature in this bug are more appropriate for the dev mailing lists.
Group: core-security
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
the proper mailing list would be dev-b2g
(Reporter)

Comment 5

4 years ago
Ok, it would had been zero cost to indicate the right email and then I'd repost that text to the mail list and forget about the post (lucky that there's no sensible data in the text), and it's zero cost to understand what somebody says, and at least warn that person instead of just do what a paper say and put it all in the open.
I've never do this you do with any of the users in any of the projects I've been.

People are first (most of all if the only thing they try to do is helping) and it doesn't cost a penny to be kind. That's not the way to create community, or at least a community that listens to people, and you loose people acting like this.
If this is your behavior with helping hands, sadly, then no more bugs and account off.
You need to log in before you can comment on or make changes to this bug.