Notifications remain after tapping on them

RESOLVED DUPLICATE of bug 1024090

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1024090
4 years ago
4 years ago

People

(Reporter: cwiiis, Unassigned)

Tracking

({regression})

unspecified
All
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

4 years ago
It seems all notifications persist after tapping on them now, they have to be swiped away to disappear.

This happens at least for:

- Screenshots
- E-mails
- Text messages

Note, tapping on a notification works as expected (launched the app and displays the relevant item), just the notification also stays.

Sometimes tapping e-mail notifications doesn't bring the e-mail app to the foreground, but I suppose that's a separate bug (and seems to happen in 1.4 too).

Updated

4 years ago
Keywords: regressionwindow-wanted

Updated

4 years ago
Component: Gaia::System::Window Mgmt → Gaia::System
Whiteboard: [systemsfe]
QA Contact: ckreinbring

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
(In reply to Chris Lord [:cwiiis] from comment #0)
> It seems all notifications persist after tapping on them now, they have to
> be swiped away to disappear.
> 
> This happens at least for:
> 
> - Screenshots
> - E-mails
> - Text messages
> 
> Note, tapping on a notification works as expected (launched the app and
> displays the relevant item), just the notification also stays.
> 
> Sometimes tapping e-mail notifications doesn't bring the e-mail app to the
> foreground, but I suppose that's a separate bug (and seems to happen in 1.4
> too).

I don't have any issue with the Messages notifications on my devices. Screenshots and Emails do not manage notifications the same way:
 - tapping the screenshot will show a preview of it
 - email app is not closing notifications but it is my understanding that this is done on purpose.
Now that I'm reproducing bug 1024090, I suspect there are high chances this one is a dupe.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1024090
blocking-b2g: 2.0+ → ---

Updated

4 years ago
Keywords: regressionwindow-wanted
Chris, can you please confirm that you had the issue in v2.0? I guess you're the one who set the "affected" flag for v2.0 since I don't see any change in the bug history.
Flags: needinfo?(chrislord.net)
(Reporter)

Comment 4

4 years ago
(In reply to Julien Wajsberg [:julienw] (away June 21 to 30) from comment #3)
> Chris, can you please confirm that you had the issue in v2.0? I guess you're
> the one who set the "affected" flag for v2.0 since I don't see any change in
> the bug history.

I thought I did, but I'm not certain - perhaps this was on a build just past the branch date(?)
Flags: needinfo?(chrislord.net)
The branch date was June 9th. You reported the bug June 12th. Too bad you didn't put the gecko+gaia hashes ;)
You need to log in before you can comment on or make changes to this bug.