If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Internal error displayed after purchasing an app on Stage

VERIFIED FIXED in 2014-06-17

Status

Marketplace
Payments/Refunds
P1
critical
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Victor Carciu, Assigned: Simone Masiero)

Tracking

({regression})

2014-06-17
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Prerequisites:
Inari device, FFOS build 1.2, MP Stage installed

Steps to reproduce:
1.Open MP-Stage app and login with valid credentials
2.Find a paid app and start the purchase process
3.Go through all purchase flow until "Payment Complete" message is displayed

Expected results:
Installation confirmation page is displayed and users are able to install the purchased app

Actual results:
Instead of Install confirmation page an error is displayed : http://screencast.com/t/GgkWkvFHT .

By pressing Cancel on the error page, a pop-up message saying "Payments cancelled" is displayed and app is not installed. The bigger problem is that I received the confirmation email from Movistar , so I think that the app was paid(tried three times and received the app purchase confirmation email every time, for same app)

Here are some logs : http://pastebin.mozilla.org/5391322
It looks like apps still isn't set up right on stage. Does it happen for all apps? Can you submit a new app to stage and try it?

Transaction is failing here:

[pay] starting transaction: /mozpay/configure-transaction
[pay] Transaction config failed. Status returned: 400
[pay] Error message: TRANS_CONFIG_FAILED

Comment 2

3 years ago
Bear in mind stage is broken at the moment due to the turning on of Bango identity, 2.0 billing and japanese characters as tracked in: bug 1023602, bug 1023601 and so on. This more than likely also related to the fact that as far as we can tell Bango is down in prod as tracked in bug 1023535.

I'll cc: this to Keir so he knows what's going on.
Assignee: nobody → keir
Priority: -- → P1
(Reporter)

Comment 3

3 years ago
Tested again and we still have an issue, but now the "Sorry , there was a problem . Please try again later" message is displayed immediately after pressing the Buy button at the end of payment flow.

Updated

3 years ago
Blocks: 1016112

Comment 4

3 years ago
Videos of an attempted purchase: http://screencast.com/t/UNf7TOTelE

Logs show:

Jun 26 23:37:08 localhost6.localdomain:  s.bango:INFO webpay:webpay:98587013-4b3d-4c40-b276-cd91bbc177ca Received notification for billing_config_id u'140852265': bango_response_code: u'NOT_SUPPORTED'; bango_response_message: u'The user or operator (e.g. MVNO) is not supported by the biller'; bango_trans_id: u'0'; bango_token: u'5baa5c19-c205-4088-a443-fe0bf441be1d'; moz_transaction: u'webpay:98587013-4b3d-4c40-b276-cd91bbc177ca'; amount: u'0'; currency: u'' :/data/addons-stage/www/payments.allizom.org/deploy-solitude-stage-20140620182523-df8f756f02/solitude/lib/bango/resources/notification.py:41

I then did a clean install of my b2g profile in case there were any offending cookies and got:

Jun 26 23:40:31 localhost6.localdomain:  s.bango:INFO webpay:webpay:f1cbe057-f420-41d5-bc65-b881c74f077f Received notification for billing_config_id u'140853355': bango_response_code: u'NOT_SUPPORTED'; bango_response_message: u'The user or operator (e.g. MVNO) is not supported by the biller'; bango_trans_id: u'0'; bango_token: u'f8ef4369-0ce3-4388-a7bb-da32c22198e8'; moz_transaction: u'webpay:f1cbe057-f420-41d5-bc65-b881c74f077f'; amount: u'0'; currency: u'' :/data/addons-stage/www/payments.allizom.org/deploy-solitude-stage-20140620182523-df8f756f02/solitude/lib/bango/resources/notification.py:41

Video: http://screencast.com/t/Pj224Ily53
Assignee: keir → simone
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

3 years ago
This seems to be an unrelated issue as it is not an Internal Error but a Not supported. 
It seems to be caused by some discrepancies in the identification. You have been identified as from Canada but in your profile the region is set to UK. This causes our API to make a currency conversion from USD to GBP when making the payment but because .99 in USD is less than the lowest price point in GBP it returns no supported options.

I am investigating about how this "tangle" happened but I believe it might be because someone in the UK used this user(or a configuration linked to it) for some testing causing it to be registered in the GBR region.

Comment 6

3 years ago
Simone, what more do you need to understand why this identity issue happened and how to resolve it?
Flags: needinfo?(simone)
(Assignee)

Comment 7

3 years ago
I would like to point out that this no longer a blocking issue for all but just related to this user. An information that we need to proceed on unblocking this specific user is the network the user is on and if it's going through wifi or operator.
Flags: needinfo?(simone)
Victor, Andy, or anyone who can reproduce it, could provide the info requested in comment #7? You can maybe use http://bango.net/whoami.aspx on device.
Flags: needinfo?(vcarciu)
Flags: needinfo?(amckay)

Comment 9

3 years ago
https://www.dropbox.com/s/32q9gbx89vqqag7/Screenshot%202014-07-02%2012.27.05.png

I mostly test using the simulator.
Flags: needinfo?(amckay)

Comment 10

3 years ago
I'm getting similar testing this on stage:

Jul  2 21:13:51 localhost6.localdomain: [10.8.83.213] w.bango:INFO Bango error: <QueryDict: {u'BillingConfigurationId': [u'143579845'], u'ResponseCode': [u'NOT_SUPPORTED'], u'P': [u''], u'Currency': [u''], u'BangoUserId': [u'2133105765'], u'MerchantTransactionId': [u'webpay:091e4ae1-bdc9-40d4-a7bb-bea60ca1fad1'], u'MozSignature': [u'd2bc67206b4d0f4dfc78fc50365ca205dd6a0b98001ff45e1e840277604fef03'], u'Token': [u'092d7715-d312-4c20-b9a9-e3457a97f6b6'], u'ResponseMessage': [u'The user or operator (e.g. MVNO) is not supported by the biller'], u'BangoTransactionId': [u'0'], u'TransactionMethods': [u''], u'Price': [u'0'], u'Network': [u'']}> :/data/addons-stage/www/marketplace.allizom.org-webpay/deploy-webpay-stage-20140702200336-203cfa59dd/webpay/webpay/bango/views.py:106

Jul  2 21:14:17 localhost6.localdomain: [10.8.83.213] w.bango:ERROR Bango payment notice for transaction uuid u'webpay:091e4ae1-bdc9-40d4-a7bb-bea60ca1fad1' failed: Client Error 400: https://payments.allizom.org/bango/notification/#012Content: {u'__all__': [u'Form field moz_signature has been tampered with. True: None; fake: d2bc67206b4d0f4dfc78fc50365ca205dd6a0b98001ff45e1e840277604fef03']}#012 :/data/addons-stage/www/marketplace.allizom.org-webpay/deploy-webpay-stage-20140702200336-203cfa59dd/webpay/webpay/bango/views.py:64

I've tried on the simulator with two different persona accounts, one which I don't think Bango has seen before.

Comment 11

3 years ago
(In reply to Simone Masiero from comment #5)
> I am investigating about how this "tangle" happened but I believe it might
> be because someone in the UK used this user(or a configuration linked to it)
> for some testing causing it to be registered in the GBR region.

Just to check, our users do move between countries and I hope this will be supported.

Comment 12

3 years ago
Simone - Have you managed to get any further since Andy provided the info?
Flags: needinfo?(simone)
(Assignee)

Comment 13

3 years ago
I understand that and my concern wasn't about the region moving but more because there was a connection with a user that had a MOZ_USER_ID that wasn't generated by Persona. We removed this connection and it would be useful to see if you can get to the flow now. Thanks.
Flags: needinfo?(simone)

Comment 14

3 years ago
Hi Simone,

What happens when a user first visits the Marketplace from a UK IP (no carrier billing) then goes back to their home network and gets a Spanish IP do they then get presented with carrier billing options? and vice versa?

We need to just understand the user experience when a user moves between various scenarios. 

If you then realise the user is a Spanish Movistar users, next time they are in the UK will they also see operator billing as an option?

Steve

Comment 15

3 years ago
(In reply to Steve Ruston from comment #14)

> If you then realise the user is a Spanish Movistar users, next time they are
> in the UK will they also see operator billing as an option?


This is the expected behaviour.  Andy's specific user was tainted by me testing with the same billing configuration here in the office in the UK. This shouldn't affect normal use cases. 

We will do some additional testing and will report back a test report covering these edge cases.

Comment 16

3 years ago
Hi Keir, so does that mean if a user did the same thing i.e. signed in for the first time in the UK but they were from Spain they wouldn't get operator billing as an option when they went back to Spain or they would get a failure?

(In reply to Keir Kettle from comment #15)
> (In reply to Steve Ruston from comment #14)
> 
> > If you then realise the user is a Spanish Movistar users, next time they are
> > in the UK will they also see operator billing as an option?
> 
> 
> This is the expected behaviour.  Andy's specific user was tainted by me
> testing with the same billing configuration here in the office in the UK.
> This shouldn't affect normal use cases. 
> 
> We will do some additional testing and will report back a test report
> covering these edge cases.

Comment 17

3 years ago
Depending on the connection in the UK, they would either be offered credit card or operator billing (DCB is still available while roaming).  When the user is detected in a region that supports carrier billing, a link is displayed that allows the user to switch (either automatically or after completing an MT SMS authentication).

Comment 18

3 years ago
Thanks Keir.

Andy can you retest when you have a moment?
Flags: needinfo?(amckay)

Updated

3 years ago
Depends on: 1035262
Flags: needinfo?(amckay)

Comment 19

3 years ago
I can now get to the Bango credit card page successfully on the simulator.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 20

3 years ago
I am still encountering "Sorry , there was a problem. Please try again later" message after pressing Buy button , with the following logcat : https://pastebin.mozilla.org/5544253
Status: RESOLVED → REOPENED
Flags: needinfo?(vcarciu)
Resolution: FIXED → ---

Comment 21

3 years ago
(In reply to Victor Carciu from comment #20)
> I am still encountering "Sorry , there was a problem. Please try again
> later" message after pressing Buy button , with the following logcat :
> https://pastebin.mozilla.org/5544253

Victor, Your pastebin is blank. Please add the logs as an attachment
(Reporter)

Comment 22

3 years ago
I am sorry , I forgot to set pastebin to retain the log for a longer time : https://pastebin.mozilla.org/5558249
(Reporter)

Comment 23

3 years ago
Created attachment 8456118 [details]
Logcat.txt

Added a txt file in order to be sure that logcat can be seen everytime
This looks related to the token checking issue (see bug 1038398)

Comment 25

3 years ago
Created attachment 8458021 [details]
logcat unsupported pay.txt

Now, after entering the PIN, "UNSUPPORTED_PAY" error message is displayed.
Please let me know if it's the same issue or I need to file a new but. 
Attached the logcat.

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Comment 26

3 years ago
Token check bug should have resolved tis 1038398
(Reporter)

Comment 27

3 years ago
This is not reproducible anymore. Verified as fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.