Closed Bug 1024578 Opened 8 years ago Closed 7 years ago

attachment notification no longer collapses duplicate keywords

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 35.0

People

(Reporter: aceman, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

Write the sentence "attachment 1 [details] [diff] [review] and attachment 2 [details] [diff] [review]" into the body of a message in compose window.
Attachment notification comes up (correctly) but contains "attachment" keyword listed twice. That didn't happen before.
May this be caused by the recent fix of bug 880261?

Please add a test for this.
Flags: in-testsuite?
Assignee: nobody → mkmelin+mozilla
Keywords: regression
Attachment #8444149 - Flags: review?(acelists)
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86 → All
Comment on attachment 8444149 [details] [diff] [review]
bug1024578_attachment_reminder_dup_keyword.patch

Review of attachment 8444149 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, works for me. Also makes tests in bug 938829 pass.

The patch is to be applied on top of patch in bug 938829.
Attachment #8444149 - Flags: review?(acelists) → review+
Attachment #8444149 - Flags: review?(standard8)
Depends on: 938829
Attachment #8444149 - Flags: review?(standard8) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/a79aee536f0e
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite? → in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 33.0
Backed out for xpcshell and mozmill failures.
https://hg.mozilla.org/comm-central/rev/f89d51af2187

https://tbpl.mozilla.org/php/getParsedLog.php?id=43830757&tree=Thunderbird-Trunk
https://tbpl.mozilla.org/php/getParsedLog.php?id=43829477&tree=Thunderbird-Trunk

Please confirm that this is green on Try before requesting checkin again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Thunderbird 33.0 → ---
It only failed on Linux in the first push. In the next push (with alta's patches) it failed only on one of the Linuxes. That looks like the usual mess with focus/non-opening menus on Linux. I don't think I can do anything about that. Usually such failures calm down (disappear) after several subsequent pushes. 

I'll check the xpcshell failure.
Flags: needinfo?(ryanvm)
What info are you requesting from me? I see perma-failing mozmill on all platforms on your push (and not just bug 1038647).
Flags: needinfo?(ryanvm)
But not perma-failing mozmill in test-attachment-reminder.js that may be caused by bug 938829.

Magnus, can you please rewrite the patch to be standalone and not applied on top of bug 938829? We need to clear up the confusion here and find out if it causes the xpcshell failure in test_attachmentChecker.js .
Flags: needinfo?(mkmelin+mozilla)
Reworked patch pushed to try https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=c6ecf61c6427 
Nothing new, but, we seem to have the new bugs bug 1039714 + bug 1039452 which are present randomly on trunk too.
Flags: needinfo?(mkmelin+mozilla)
Yeah, try fails in test-attachment-reminder.js even before the patch here. That is what I wanted to explain to Ryan in comment 5.

Can we propose this for trunk when you attach it?
The rebased patch. (Stole a function from your patch).

I would hold off on landing it a bit yet, to see what the those oranges are about.
Attachment #8444149 - Attachment is obsolete: true
Attachment #8457454 - Flags: review+
Good time to push this now? :)
Flags: needinfo?(mkmelin+mozilla)
https://hg.mozilla.org/comm-central/rev/cfeb888030d5 -> FIXED
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Flags: needinfo?(mkmelin+mozilla)
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 35.0
Blocks: 938829
No longer depends on: 938829
This needs to be backed out or fixed due to a test failure.

https://hg.mozilla.org/comm-central/rev/86a44b43b555

https://tbpl.mozilla.org/?tree=Thunderbird-Trunk&rev=cfeb888030d5
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Oh, failure in xpcshell now.
Ok so this should do it.
Attachment #8457454 - Attachment is obsolete: true
Attachment #8487824 - Flags: review+
Yes.
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/c4465beae1b5 -> FIXED
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.