Closed Bug 1024656 Opened 5 years ago Closed 5 years ago

[B2G][Homescreen] Packaged apps downloaded from Marketplace do not display icons on homescreen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.4 unaffected, b2g-v2.0 affected)

RESOLVED DUPLICATE of bug 1024280
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- affected

People

(Reporter: bzumwalt, Unassigned)

Details

(Keywords: regression, smoketest)

Attachments

(2 files)

Attached image Screenshot
Description:
When user downloads a packaged app from Marketplace the icons appear as blank white rocket bar icons on homescreen. When user restarts phone the icons appear as normal. Any additional packaged apps downloaded after restart appear as blank white icons and require another restart to appear correctly. Hosted app icons appear correctly.


Repro Steps:
1) Update a Flame to 20140612000201
2) Launch Marketplace
3) Download any packaged app
4) Return to homescreen


Actual:
Packaged apps appear as blank icons on homescreen.

Expected:
All downloaded app icons appear normal on the homescreen

Environmental Variables:
Device: Flame 2.0
Build ID: 20140612000201
Gaia: 2bb66630315299ca947e40fcec23c9f7ea012111
Gecko: 670d69879f0e
Version: 32.0a2 (2.0) 
Firmware Version: v10G-2

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 


Notes:
Repro frequency: 3/3, 100%
See attached: screenshot & logcat
Attached file Logcat
Issue does NOT occur on Flame 1.4

Result: All downloaded app icons appear normal on the homescreen

1.4 Environmental Variables:
Device: Flame 1.4
BuildID: 20140612000202
Gaia: 7fc73d4cb1bece31f50e8ccf6fb98af3984a9ebf
Gecko: bcd308fbbf38
Version: 30.0
Firmware Version: v10G-2
QA Whiteboard: [QAnalyst-Triage?]
Keywords: qaurgent
Issue occurs on yesterdays 2.0 Buri

Result: Packaged apps appear as blank icons on homescreen.

Environmental Variables:
Device: Buri 2.0
Build ID: 20140611000203
Gaia: 67b1679554cc517a5213aa2a746de26afe977eb8
Gecko: b504ab65e7f0
Version: 32.0a2 (2.0) 
Firmware Version: v1.2-device.cfg
blocking-b2g: --- → 2.0?
QA Contact: jmercado
No longer blocks: vertical-homescreen
Status: NEW → RESOLVED
blocking-b2g: 2.0? → ---
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1024280
QA Whiteboard: [QAnalyst-Triage?]
You need to log in before you can comment on or make changes to this bug.