If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Flame][Camera] Image preview is displaying incorrectly as only a grey screen

RESOLVED DUPLICATE of bug 1024563

Status

Firefox OS
Gaia::Camera
RESOLVED DUPLICATE of bug 1024563
3 years ago
3 years ago

People

(Reporter: rpribble, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 unaffected, b2g-v1.4 affected, b2g-v2.0 unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8439524 [details]
Screenshot.png

Description:
If the user takes a photo then taps the preview icon to the left of the capture button, the preview will not display correctly.  The grey background will show blank and the preview never loads.

Repro Steps:
1) Update a Flame to BuildID: 20140612000202
2) Tap camera icon
3) Take a photo
4) Tap the preview icon to the left of capture button

Actual:
Preview shows only a blank grey screen.

Expected:
User sees preview of image captured.

v1.4 Environmental Variables:
Device: Flame v1.4 MOZ ril
BuildID: 20140612000202
Gaia: 7fc73d4cb1bece31f50e8ccf6fb98af3984a9ebf
Gecko: bcd308fbbf38
Version: 30.0
Firmware Version: v121-2


Notes:


Repro frequency: 100%
See attached: Screenshot, logcat
(Reporter)

Comment 1

3 years ago
Created attachment 8439558 [details]
LogcatFromBuri.txt

This issue does not repro on the Flame v2.0 MOZ ril.

This issue DOES repro on the Buri v1.4 MOZ ril. 

This issue DOES repro on the Open_C v1.4 MOZ ril

This issue does not repro on the Buri v1.3 MOZ ril.

This issue does not repro on the Open_C v1.3 MOZ ril.


v2.0 Environmental Variables:
Device: Flame v2.0 MOZ
BuildID: 20140612000201
Gaia: 2bb66630315299ca947e40fcec23c9f7ea012111
Gecko: 670d69879f0e
Version: 32.0a2
Firmware Version: v121-2

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ ril
BuildID: 20140612000202
Gaia: 7fc73d4cb1bece31f50e8ccf6fb98af3984a9ebf
Gecko: bcd308fbbf38
Version: 30.0
Firmware Version: v1.2-device.cfg

v1.3 Environmental Variables:
Device: Buri v1.3 MOZ
BuildID: 20140602024006
Gaia: 5bd226b03a2d63dfe9df204f7c0afb9984e8fd42
Gecko: 14b755c65af8
Version: 28.0
Firmware Version: v1.2-device.cfg

v1.4 Environmental Variables:
Device: Open_C v1.4 MOZ
BuildID: 20140612000202
Gaia: 7fc73d4cb1bece31f50e8ccf6fb98af3984a9ebf
Gecko: bcd308fbbf38
Version: 30.0
Firmware Version: P821A10v1.0.0B06_LOG_DL

v1.3 Environmental Variables:
Device: Open_C v1.3 MOZ
BuildID: 20140505052400
Gaia: Unknown Git commit; build date shown here.
Gecko:
Version: 28.0
Firmware Version: P821A10v1.0.0B06_LOG_DL
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
(Reporter)

Updated

3 years ago
status-b2g-v1.3: --- → unaffected
status-b2g-v2.0: --- → unaffected
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Resolution: --- → DUPLICATE
Duplicate of bug: 1024563
You need to log in before you can comment on or make changes to this bug.