[B2G][Testing][Flame] Flame white screens during automated testing of test_settings_wifi

RESOLVED DUPLICATE of bug 1016821

Status

--
major
RESOLVED DUPLICATE of bug 1016821
4 years ago
4 years ago

People

(Reporter: dwong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fromAutomation])

(Reporter)

Description

4 years ago
During repeat testing of test_settings_wifi through Jenkins the Flame device will freeze with a white screen and be unrecognizable adb (not listed on adb devices) The following are the logs of the failed run from Jenkins and the logcat from running the test.


Jenkins Log:
15:44:52 FAILED (errors=1)
15:44:52 
15:44:52 REPEAT 5
15:44:52 -------
15:44:52 TEST-START test_settings_wifi.py
15:44:52 starting httpd
15:44:52 Traceback (most recent call last):
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/bin/gaiatest", line 9, in <module>
15:44:52     load_entry_point('gaiatest==0.23', 'console_scripts', 'gaiatest')()
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/tests/python/gaia-ui-tests/gaiatest/runtests.py", line 49, in main
15:44:52     cli(runner_class=GaiaTestRunner, parser_class=GaiaTestOptions)
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/runtests.py", line 28, in cli
15:44:52     runner = startTestRunner(runner_class, options, tests)
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/runtests.py", line 19, in startTestRunner
15:44:52     runner.run_tests(tests)
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/runner/base.py", line 828, in run_tests
15:44:52     self.run_test_sets()
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/runner/base.py", line 1050, in run_test_sets
15:44:52     self.run_test_set(in_process_tests)
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/runner/base.py", line 1027, in run_test_set
15:44:52     self.run_test(test['filepath'], test['expected'], test['oop'])
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/runner/base.py", line 1003, in run_test
15:44:52     results = runner.run(suite)
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/runner/base.py", line 281, in run
15:44:52     pre_run_func()
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/runner/base.py", line 266, in b2g_pre_run
15:44:52     self.b2g_pid = get_b2g_pid(get_dm(self.marionette))
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/runner/mixins/b2g.py", line 22, in get_dm
15:44:52     return mozdevice.DeviceManagerADB(**kwargs)
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/local/lib/python2.7/site-packages/mozdevice-0.36-py2.7.egg/mozdevice/devicemanagerADB.py", line 66, in __init__
15:44:52     self._verifyDevice()
15:44:52   File "/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/.env/local/lib/python2.7/site-packages/mozdevice-0.36-py2.7.egg/mozdevice/devicemanagerADB.py", line 655, in _verifyDevice
15:44:52     raise DMError("unable to connect to device")
15:44:52 mozdevice.devicemanager.DMError: unable to connect to device
15:44:52 + OUT=1
15:44:52 + cat jobs.txt
15:44:52 2256
15:44:52 ++ tail -1 jobs.txt
15:44:52 + kill -9 2256
15:44:52 /tmp/hudson6014710706461348146.sh: line 14: kill: (2256) - No such process
15:44:52 + exit 1
15:44:52 Build step 'Execute shell' marked build as failure
15:44:52 Archiving artifacts
15:44:52 [htmlpublisher] Archiving HTML reports...
15:44:52 [htmlpublisher] Archiving at BUILD level /var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/tests/python/gaia-ui-tests/results to /Users/Shared/Jenkins/Home/jobs/b2g.flame.mozilla-central.adhoc.test_settings_wifi/builds/2014-06-12_15-37-30/htmlreports/HTML_Report
15:44:52 ERROR: Specified HTML directory '/var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/tests/python/gaia-ui-tests/results' does not exist.
15:44:52 Recording test results
15:44:52 Sending e-mails to: webqa-ci@mozilla.org

15:44:52 IRC notifier plugin: Sending notification to: #mozwebqa
15:44:52 Finished: FAILURE

Logcat log:


I/Gecko   ( 3338): 1402613078286	Marionette	DEBUG	accepted connection on 127.0.0.1:36366
I/Gecko   ( 3338): 1402613078305	Marionette	INFO	could not load listener into content for page: chrome://b2g/content/shell.html
I/Gecko   ( 3338): 1402613078308	Marionette	INFO	sendToClient: {"from":"0","value":{"browserName":"B2G","browserVersion":"33.0a1","platformName":"ANDROID","platformVersion":"33.0a1","handlesAlerts":false,"nativeEvents":false,"rotatable":true,"secureSsl":false,"takesElementScreenshot":true,"takesScreenshot":true,"platform":"ANDROID","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","appBuildId":"20140612142128","device":"flame","version":"33.0a1","b2g":true}}, {8d80067e-9509-48b8-ba5f-64590935b110}, {8d80067e-9509-48b8-ba5f-64590935b110}
I/Gecko   ( 3338): 1402613078320	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {cdd7cdc8-98c3-4e37-9259-f31882b84a4c}, {cdd7cdc8-98c3-4e37-9259-f31882b84a4c}
I/Gecko   ( 3338): 1402613078326	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {248c3c9b-c6c7-4cd4-9137-7ec7aa703953}, {248c3c9b-c6c7-4cd4-9137-7ec7aa703953}
I/Gecko   ( 3338): 1402613078341	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {53558f55-4b38-4098-939c-af64ed29ed0b}, {53558f55-4b38-4098-939c-af64ed29ed0b}
I/Gecko   ( 3338): 1402613078359	Marionette	DEBUG	Got request: setTestName, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"33.0a1","takesScreenshot":true,"appBuildId":"20140612142128","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"33.0a1","device":"flame","b2g":true,"nativeEvents":false,"platformVersion":"33.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"setTestName","parameters":{"value":"test_settings_wifi.py TestSettingsWifi.test_connect_to_wifi_via_settings_app"}}, id: {fd2ab5f7-2acf-4af3-9046-69b9f771d05f}
I/Gecko   ( 3338): 1402613078361	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {fd2ab5f7-2acf-4af3-9046-69b9f771d05f}, {fd2ab5f7-2acf-4af3-9046-69b9f771d05f}
I/Gecko   ( 3338): 1402613078369	Marionette	DEBUG	Got request: execute, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"33.0a1","takesScreenshot":true,"appBuildId":"20140612142128","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"33.0a1","device":"flame","b2g":true,"nativeEvents":false,"platformVersion":"33.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"executeScript","parameters":{"scriptTimeout":null,"specialPowers":false,"script":"log('TEST-START: /var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_wifi.py:test_connect_to_wifi_via_settings_app')","newSandbox":true,"args":[],"filename":"marionette_test.py","line":342}}, id: {c68ffd06-25ab-4a82-b424-6e22ff07f28e}
I/Gecko   ( 3338): MARIONETTE LOG: INFO: TEST-START: /var/jenkins/workspace/b2g.flame.mozilla-central.adhoc.test_settings_wifi/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_wifi.py:test_connect_to_wifi_via_settings_app
I/Gecko   ( 3338): 1402613078378	Marionette	INFO	sendToClient: {"from":"0","value":null}, {c68ffd06-25ab-4a82-b424-6e22ff07f28e}, {c68ffd06-25ab-4a82-b424-6e22ff07f28e}
I/Gecko   ( 3338): 1402613078384	Marionette	INFO	sendToClient: {"from":"0","value":{"browserName":"B2G","browserVersion":"33.0a1","platformName":"ANDROID","platformVersion":"33.0a1","handlesAlerts":false,"nativeEvents":false,"rotatable":true,"secureSsl":false,"takesElementScreenshot":true,"takesScreenshot":true,"platform":"ANDROID","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","appBuildId":"20140612142128","device":"flame","version":"33.0a1","b2g":true}}, {661c59c3-f860-46ea-988e-84c4de59ad0f}, {661c59c3-f860-46ea-988e-84c4de59ad0f}
I/ServiceManager(  275): service 'media.resource_manager' died
I/ServiceManager(  275): service 'SurfaceFlinger' died
I/ServiceManager(  275): service 'permission' died
I/ServiceManager(  275): service 'display.qservice' died
D/nfcd    (  289):  8 of bytes to be sent... data=0x0 ret=0
E/QCALOG  (  388): [MessageQ] ProcessNewMessage: [XT-CS] unknown deliver target [OS-Agent]
E/QCALOG  (  388): [MessageQ] ProcessNewMessage: [XTWiFi-PE] unknown deliver target [OS-Agent]
E/QCALOG  (  388): [MessageQ] ProcessNewMessage: [XTWWAN-PE] unknown deliver target [OS-Agent]


Build info:
Gaia      90777363ed0a4e6d32612074a12fb2c73c353a25
Gecko     https://hg.mozilla.org/mozilla-central/rev/aab3362f97e9
BuildID   20140612142128
Version   33.0a1
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014

This also occurred when using the v10G-2 base image (incremental 94)
Blocks: 801898
Dylan, if you get a chance, can you see if this repeats manually, same build?  Thx.
Flags: needinfo?(dwong)
Whiteboard: [fromAutomation]
(Reporter)

Comment 2

4 years ago
I didn't seem to be able to produce it manually.
Flags: needinfo?(dwong)
Walter, can you/the team see if you can also reproduce/get some traction from developers on it?  Thanks!
Flame m-c
Gaia      90777363ed0a4e6d32612074a12fb2c73c353a25
Gecko     https://hg.mozilla.org/mozilla-central/rev/aab3362f97e9
BuildID   20140612160203
Version   33.0a1
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014

Run test_settings_wifi.py with repeat=5 on my PC, and get the following result.
SUMMARY
-------
passed: 6
failed: 0
todo: 0
I run into white screen once when I do manual testing, but just once, STR unknown.
I think this is a vendor bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1016821
Moving the tracking bug to the dupe.
No longer blocks: 801898
You need to log in before you can comment on or make changes to this bug.