Closed Bug 1024849 Opened 5 years ago Closed 5 years ago

No password prompt after receiving "401 Unauthorized"

Categories

(Firefox :: Untriaged, defect, major)

30 Branch
x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1023748

People

(Reporter: Mike.Radford, Unassigned)

Details

(Keywords: wsec-authorization)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140421221237

Steps to reproduce:

When logging into Outlook 365, several 302 redirects are performed directing the browser back to an authorization server. When that server responds with "401 Unauthorized" (accompanied with the response header WWW-Authenticate: NegotiateNTLM), Firefox no longer presents a username/password prompt. 

This failure began with Firefox 30. I reverted back to 29 and it correctly prompts for a password. 

I've not yet determined if it's the NTLM or if it's the fact that the 401 followed several redirects, or if it's that those redirects were to different domains.



Actual results:

Received no prompt, and therefore login fails.



Expected results:

Should have been presented with a username/password prompt, so that the request could be performed again with the proper Authorization request header.
Severity: normal → major
It's NTLM. See bug 1023748.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1023748
You need to log in before you can comment on or make changes to this bug.