[Keyboard] LayoutLoader should load all keyboards exposed to Keyboards object, not just the named one

RESOLVED FIXED in 2.0 S4 (20june)

Status

Firefox OS
Gaia::Keyboard
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: timdream, Assigned: timdream)

Tracking

({regression})

unspecified
2.0 S4 (20june)
x86
Mac OS X
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [p=1])

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1015643 +++

I made a mistake in the said bug where LoayoutLoader.initKeyboard(layoutName) only init the named layout. A file might come with multiple layouts so it must load all of it.

STR:

1. enable Pinyin IME
2. Press ?123 key

Expected:

1. Switch to the special Pinyin symbol layout

Actual:

1. Do nothing


another STR (need re-flash to enable Greek layout):

1. Switch to Greek
2. Go to Messsage app -> new message
3. Tap Shift key

Expected:

1. Shift key should be disabled because we should be in all-caps ASCI-only fake Greek layout

Actual:

1. I don't know yet but it should be something different.
Comment on attachment 8439734 [details] [review]
mozilla-b2g:master PR#20479

I am thankful that we didn't land the previous bug on v2.0!
Attachment #8439734 - Flags: review?(rlu)
Target Milestone: --- → 2.0 S4 (20june)
Comment on attachment 8439734 [details] [review]
mozilla-b2g:master PR#20479

Thanks for finding this issue, r+.

--
Guess we could catch this earlier if we have the following integration tests, 
bub 949961: Integration tests for Pinyin IME & input method API composition methods 
bug 1024885: Add integration test to cover Greek SMS keyboard layout (just filed)

Will try to work on those bugs as soon as possible.
Attachment #8439734 - Flags: review?(rlu) → review+
master: https://github.com/mozilla-b2g/gaia/commit/74c33aab2621fcbf9c5d01e1aff0599fb7787390
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.