[NFC][Contact] Could not share the contact that combine with local & Facebook-linked data when initial creating the combined contact

VERIFIED DUPLICATE of bug 1015060

Status

Firefox OS
NFC
VERIFIED DUPLICATE of bug 1015060
4 years ago
4 years ago

People

(Reporter: Alison Shiue, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Gaia      a3a5322692578e0a577fb7fa08e32144b2b05ba3
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/0293597de41f
BuildID   20140612160201
Version   32.0a2

STR:
1. launch "settings" app for 2 phones
2. turn on "NFC" for 2 phones
3. device A sync a FB friend to contact
4. add phone number on the FB contact
5. tap two phones together
6. slide the shrinking UI to share the combined contact to device B

Expected result:
device B receive the FB contact's local data successfully

Actual result:
device A could not share the FB contact's local data unless relaunch contact app
(Reporter)

Comment 1

4 years ago
The issue seems a side effect from bug 997599
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.0?

Comment 2

4 years ago
Michal, I wonder if you could help this?
Flags: needinfo?(mbudzynski)
Yup, I'm on it now.
Flags: needinfo?(mbudzynski)
We don't need to restart the app to make it working - it's enough to back from the details view to the list view, and then trying again. It's happening because when we save the contact we don't broadcast changes through all the views, so some views get old references to edited contact. This will be fixed by Bug 1015060 (will land very soon, it's just waiting for the r?) prepared yesterday by :arcturus. I've tested the patch against the scenario described in Comment 0 and it worked perfectly. Threating this bug as a duplicate then. Thanks.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1015060
Clearing the nom as dup is tracked.
blocking-b2g: 2.0? → ---
(Reporter)

Comment 6

4 years ago
Verified on
Gaia      23e06c3624309db22ad9cb736d89700768b42b36
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/12161a842a8e
BuildID   20140618160200
Version   32.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.